32 lines
947 B
Text
32 lines
947 B
Text
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
pkgname=py3-pytube
|
|
#_pkgreal is used by apkbuild-pypi to find modules at PyPI
|
|
_pkgreal=pytube
|
|
pkgver=15.0.0
|
|
pkgrel=0
|
|
pkgdesc="Python 3 library for downloading YouTube Videos."
|
|
url="https://pypi.python.org/project/pytube"
|
|
arch="noarch"
|
|
license="Unlicense"
|
|
depends="python3"
|
|
checkdepends="python3-dev"
|
|
makedepends="py3-setuptools py3-gpep517 py3-wheel"
|
|
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/p/pytube/pytube-$pkgver.tar.gz"
|
|
builddir="$srcdir/$_pkgreal-$pkgver"
|
|
subpackages="$pkgname-pyc"
|
|
|
|
build() {
|
|
gpep517 build-wheel \
|
|
--wheel-dir .dist \
|
|
--output-fd 3 3>&1 >&2
|
|
}
|
|
|
|
package() {
|
|
python3 -m installer -d "$pkgdir" \
|
|
.dist/*.whl
|
|
}
|
|
|
|
sha512sums="
|
|
68174a3392e5f2ff3059dc1f301783b1ce0a0334044b9e96b6066052066b3c3cee93bfc87449d10589795b3e43055cf6d629f1cac21bfc9ea2c4249b5f264c26 py3-pytube-15.0.0.tar.gz
|
|
"
|