ayaports/testing/py3-webauthn/APKBUILD

35 lines
979 B
Text

# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
_pyname=webauthn
pkgname="py3-$_pyname"
pkgver=1.11.1
pkgrel=0
arch="noarch"
pkgdesc="A Python3 implementation of the WebAuthn API focused on making it easy to leverage the power of WebAuthn."
url="https://pypi.python.org/project/$_pyname"
license="BSD-3-Clause"
makedepends="
py3-setuptools
py3-gpep517
py3-wheel
py3-installer
"
options="!check" # No testsuite
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
subpackages="$pkgname-pyc"
build() {
gpep517 build-wheel \
--wheel-dir dist \
--output-fd 3 3>&1 >&2
}
package() {
python3 -m installer -d "$pkgdir" \
dist/*.whl
}
sha512sums="
29e3df7adfed9fdbe8bfe264e207c45e2426ec10c48daf90347a7fe6070f00280c8102da00335a8f5b9b7efeba9fa2fe033dcaf656ec4f95a7566bcc6a5729b2 py3-webauthn-1.11.1.tar.gz
"