ayaports/testing/py3-langdetect/APKBUILD

45 lines
986 B
Text

# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=py3-langdetect
_pyname="langdetect"
pkgver=1.0.9
pkgrel=0
arch="noarch"
pkgdesc="Language detection library ported from Google's language-detection"
url="https://pypi.python.org/project/$_pyname"
license="Apache-2.0"
depends="
py3-six
"
makedepends="
py3-setuptools
py3-gpep517
py3-installer
py3-wheel
"
checkdepends="
py3-pytest
"
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
subpackages="$pkgname-pyc"
build() {
gpep517 build-wheel \
--wheel-dir dist \
--output-fd 3 3>&1 >&2
}
check() {
pytest -v
}
package() {
python3 -m installer -d "$pkgdir" \
dist/*.whl
}
sha512sums="
7558d674c47b080c79e43a00a25d2c7f77188cf60bea2cecb3bebb803d75e1aa42b43c74bd26ea1b541f4cb927421908882cbec01a91f0913984217e71ccc8db py3-langdetect-1.0.9.tar.gz
"