31 lines
989 B
Text
31 lines
989 B
Text
# Maintainer: Drew DeVault <sir@cmpwn.com>
|
|
pkgname=py3-qtwebengine
|
|
pkgver=5.14.0
|
|
pkgrel=0
|
|
pkgdesc="Python 3 bindings for QtWebEngine"
|
|
url="https://www.riverbankcomputing.com/software/pyqtwebengine/intro"
|
|
# mips, ppc64le, s390x: not supported
|
|
arch="all !ppc64le !s390x !armhf !mips !mips64" # armhf blocked by py3-qt5 -> qt5-qtdeclarative
|
|
license="GPL-2.0-or-later"
|
|
depends="python3"
|
|
makedepends="python3-dev py3-qt5 qt5-qtwebengine-dev py-sip-dev"
|
|
source="https://pypi.python.org/packages/source/P/PyQtWebEngine/PyQtWebEngine-$pkgver.tar.gz"
|
|
builddir="$srcdir"/PyQtWebEngine-"$pkgver"
|
|
|
|
build() {
|
|
python3 configure.py \
|
|
--qmake /usr/lib/qt5/bin/qmake \
|
|
--sip /usr/bin/sip \
|
|
--sipdir /usr/share/sip/PyQt5
|
|
make
|
|
}
|
|
|
|
check() {
|
|
make check
|
|
}
|
|
|
|
package() {
|
|
make -j1 DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
|
|
}
|
|
|
|
sha512sums="c5274ce5ba1c80c6851971c3e18acf33121cd5863f613bd1789fdb40323b52429b55b54f3dcbb3127c85343e11f14c004ad54711b2b59cab95fd440f90fe5f2e PyQtWebEngine-5.14.0.tar.gz"
|