31 lines
868 B
Text
31 lines
868 B
Text
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
pkgname=i18nspector
|
|
pkgver=0.27.1
|
|
pkgrel=0
|
|
pkgdesc="checking tool for gettext POT, PO and MO files"
|
|
url="https://jwilk.net/software/i18nspector"
|
|
arch="noarch"
|
|
license="MIT"
|
|
depends="py3-polib py3-rply"
|
|
checkdepends="python3-dev py3-pytest"
|
|
makedepends="py3-docutils py3-setuptools py3-gpep517 py3-wheel perl"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/jwilk/i18nspector/archive/refs/tags/$pkgver.tar.gz"
|
|
subpackages="$pkgname-doc"
|
|
options="!check" # test failure
|
|
|
|
build() {
|
|
make -C doc
|
|
}
|
|
|
|
check() {
|
|
pytest -v
|
|
}
|
|
|
|
package() {
|
|
make PREFIX=/usr DESTDIR="$pkgdir" install
|
|
}
|
|
|
|
sha512sums="
|
|
b6b3d68ba03ead88393d6fff7233ec6d67196496f3eaaba8fe036ac9976746370885f72ec3c4e6b4dbf892f3d04c505a306900fafade1623e90ec9c1ad546166 i18nspector-0.27.1.tar.gz
|
|
"
|