66 lines
2.3 KiB
Text
66 lines
2.3 KiB
Text
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
|
|
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
|
|
pkgname=shntool
|
|
pkgver=3.0.10
|
|
pkgrel=4
|
|
pkgdesc="A multi-purpose WAVE data processing and reporting utility"
|
|
url="http://shnutils.freeshell.org/shntool/"
|
|
arch="all"
|
|
license="GPL-2.0-or-later"
|
|
makedepends="sox"
|
|
subpackages="$pkgname-doc"
|
|
source="http://shnutils.freeshell.org/shntool/dist/src/shntool-$pkgver.tar.gz
|
|
shntool-3.0.10-large-size.patch
|
|
shntool-3.0.10-large-times.patch
|
|
24bit.patch
|
|
"
|
|
|
|
build() {
|
|
update_config_sub
|
|
./configure \
|
|
--build=$CBUILD \
|
|
--host=$CHOST \
|
|
--prefix=/usr \
|
|
--sysconfdir=/etc \
|
|
--mandir=/usr/share/man \
|
|
--infodir=/usr/share/info \
|
|
--localstatedir=/var
|
|
make
|
|
}
|
|
|
|
package() {
|
|
make DESTDIR="$pkgdir" install
|
|
}
|
|
|
|
check() {
|
|
# Check if shntools are operational
|
|
mkdir -p "$builddir/test"
|
|
cd "$builddir/test"
|
|
ln -s ../src/shntool shninfo
|
|
ln -s ../src/shntool shncue
|
|
ln -s ../src/shntool shnsplit
|
|
ln -s ../src/shntool shnjoin
|
|
ln -s ../src/shntool shncmp
|
|
sox -r 44100 -b 16 -n beat1.wav synth 0.4 sin 347 sin 357 vol 0.5
|
|
sox -r 44100 -b 16 -n beat2.wav synth 0.5 sin 359 sin 357 vol 0.5
|
|
sox -r 44100 -b 16 -n beat3.wav synth 0.6 sin 459 sin 438 vol 0.5
|
|
./shninfo beat1.wav | grep -q 70604
|
|
./shninfo beat2.wav | grep -q 88244
|
|
./shncue beat1.wav beat2.wav beat3.wav > joined.cue
|
|
./shnjoin beat1.wav beat2.wav beat3.wav
|
|
./shninfo joined.wav | grep -q 265820
|
|
./shnsplit -f joined.cue joined.wav
|
|
./shninfo split-track01.wav | grep -q 70604
|
|
./shninfo split-track03.wav | grep -q 105884
|
|
./shncmp split-track01.wav beat1.wav
|
|
./shncmp split-track02.wav beat2.wav
|
|
cd "$builddir"
|
|
rm -r test
|
|
}
|
|
|
|
sha512sums="
|
|
2150d7123860abb54a56a1615bda991ed3713d73c338723f28b7d01a63c49a47809be16dc57b5b4edeee1567b003f9a4b54945c1cd08440f9503d22b91eaa06d shntool-3.0.10.tar.gz
|
|
fc44bca63d79b279db6d275caaacdb73cbebd6b902276a9052f005146fa125f4674e3cf559d46405637a337192f4a38f9bec4836af46e7ae52e4f220352c1ba7 shntool-3.0.10-large-size.patch
|
|
9780f22d93e20dd01d18067978bdf6cbb0b460bb80f41c4f4752b3322c3d70182b3acf35b789e30fc36ca52af6127e24c00599fb49b916f01448613721a94ebe shntool-3.0.10-large-times.patch
|
|
3c9cdd7936a6572a3c9dfc7575f5ff9a0981dd557add8e1113454487091c7b161040d25d3266937449295a1bb5317ee3515a84c3d7168360bf84643ed828e202 24bit.patch
|
|
"
|