ayaports/backports/py3-numpy-stl/APKBUILD

34 lines
1,014 B
Text

# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-numpy-stl
pkgver=3.0.1
pkgrel=2
pkgdesc="Library for working with STLs"
url="https://github.com/WoLpH/numpy-stl"
# s390x: no py3-utils
arch="noarch !s390x"
license="BSD-3-Clause"
depends="python3 py3-utils py3-numpy"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/wolph/numpy-stl/releases/download/v$pkgver/numpy-stl-$pkgver.tar.gz"
builddir="$srcdir/numpy-stl-$pkgver"
build() {
python3 setup.py build
}
check() {
# deselected test needs xvfb-run and fails
pytest \
--deselect tests/test_ascii.py::test_use_with_qt_with_custom_locale_decimal_delimeter
}
package() {
python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
d01abb8f54738600ce36c8c44e1392957061030e7accbbfa0352aea4a904323a96712099146b311ce9518f243317c25c47cfb30930469602c0ad439de9f43c5f py3-numpy-stl-3.0.1.tar.gz
"