ayaports/backports/py3-mapbox-earcut/APKBUILD

35 lines
1 KiB
Text

# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer:
pkgname=py3-mapbox-earcut
pkgver=1.0.1
pkgrel=2
pkgdesc="Python bindings for the mapbox earcut c++ library"
url="https://github.com/skogler/mapbox_earcut_python"
arch="all"
license="ISC"
depends="py3-numpy"
makedepends="py3-setuptools py3-pybind11-dev python3-dev py3-gpep517"
checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://github.com/skogler/mapbox_earcut_python/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/mapbox_earcut_python-$pkgver"
build() {
gpep517 build-wheel \
--wheel-dir .dist \
--output-fd 3 3>&1 >&2
}
check() {
python3 -m venv --clear --without-pip --system-site-packages .testenv
gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
.testenv/bin/python3 -m pytest
}
package() {
gpep517 install-wheel --destdir "$pkgdir" \
.dist/*.whl
}
sha512sums="
cdb32585cbaf74c15e59af0ae70d983dd2f9bc9cfe1b59b3eadc4d442f7d962241854b589a035deae67cacd9334833b911d0981f0d417fe587348fc7d24f0c0a py3-mapbox-earcut-1.0.1.tar.gz
"