32 lines
1,000 B
Text
32 lines
1,000 B
Text
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
|
|
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
|
|
pkgname=py3-mapbox-earcut
|
|
pkgver=1.0.1
|
|
pkgrel=0
|
|
pkgdesc="Python bindings for the mapbox earcut c++ library"
|
|
url="https://github.com/skogler/mapbox_earcut_python"
|
|
arch="all"
|
|
license="ISC"
|
|
depends="py3-numpy"
|
|
makedepends="py3-setuptools py3-pybind11-dev python3-dev"
|
|
checkdepends="pytest"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/skogler/mapbox_earcut_python/archive/refs/tags/v$pkgver.tar.gz"
|
|
builddir="$srcdir/mapbox_earcut_python-$pkgver"
|
|
|
|
build() {
|
|
python3 setup.py build
|
|
}
|
|
|
|
check() {
|
|
python3 -m venv --clear --without-pip --system-site-packages test-env
|
|
test-env/bin/python3 setup.py install
|
|
test-env/bin/python3 -m pytest
|
|
}
|
|
|
|
package() {
|
|
python3 setup.py install --skip-build --root="$pkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
cdb32585cbaf74c15e59af0ae70d983dd2f9bc9cfe1b59b3eadc4d442f7d962241854b589a035deae67cacd9334833b911d0981f0d417fe587348fc7d24f0c0a py3-mapbox-earcut-1.0.1.tar.gz
|
|
"
|