55 lines
1.4 KiB
Text
55 lines
1.4 KiB
Text
# Contributor: lauren n. liberda <lauren@selfisekai.rocks>
|
|
maintainer="lauren n. liberda <lauren@selfisekai.rocks>"
|
|
pkgname=py3-flask-limiter
|
|
pkgver=3.9.2
|
|
pkgrel=0
|
|
pkgdesc="Rate Limiting extension for Flask"
|
|
url="https://github.com/alisaifee/flask-limiter"
|
|
arch="noarch"
|
|
license="MIT"
|
|
depends="
|
|
py3-flask
|
|
py3-limits
|
|
py3-ordered-set
|
|
py3-rich
|
|
python3
|
|
"
|
|
makedepends="py3-setuptools py3-gpep517"
|
|
checkdepends="
|
|
py3-flask-restful
|
|
py3-flask-restx
|
|
py3-limits-mongodb
|
|
py3-limits-redis
|
|
py3-pytest
|
|
py3-pytest-cov
|
|
"
|
|
subpackages="$pkgname-pyc"
|
|
source="
|
|
https://github.com/alisaifee/flask-limiter/archive/refs/tags/$pkgver/flask-limiter-$pkgver.tar.gz
|
|
|
|
our-std-is-good-enough.patch
|
|
"
|
|
builddir="$srcdir/flask-limiter-$pkgver"
|
|
options="!check" # tests depend on unpackaged modules
|
|
|
|
build() {
|
|
gpep517 build-wheel \
|
|
--wheel-dir .dist \
|
|
--output-fd 3 3>&1 >&2
|
|
}
|
|
|
|
check() {
|
|
python3 -m venv --clear --without-pip --system-site-packages .testenv
|
|
gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
|
|
.testenv/bin/python3 -m pytest
|
|
}
|
|
|
|
package() {
|
|
gpep517 install-wheel --destdir "$pkgdir" \
|
|
.dist/*.whl
|
|
}
|
|
|
|
sha512sums="
|
|
69e488a641ab39c088185fabcde19ebb4cbe1683e9143efdf146163bb0254e0c4f8b4b72df407542d540394e7e3b2d7498b9c93c25ae8a8128e05e319f342318 flask-limiter-3.9.2.tar.gz
|
|
1b90e9134076cda249695d5ea741db9d205a2ae452c7d6edfe01eb37a221ce6f64b0e8ddcdbbee9b0e0fb16a28e5eabf14f1c1e41e965c7e3b93ea4f42caf553 our-std-is-good-enough.patch
|
|
"
|