diff --git a/community/dotnet7-build/APKBUILD b/community/dotnet7-build/APKBUILD
index cf29fff..e908ad6 100644
--- a/community/dotnet7-build/APKBUILD
+++ b/community/dotnet7-build/APKBUILD
@@ -16,9 +16,17 @@
# - CVE-2023-33126
# - CVE-2023-33128
# - CVE-2023-33135
+# 7.0.109-r0:
+# - CVE-2023-33127
+# - CVE-2023-33170
+# 7.0.110-r0:
+# - CVE-2023-38178
+# - CVE-2023-35390
+# - CVE-2023-38180
+# - CVE-2023-35391
pkgname=dotnet7-build
-pkgver=7.0.108
+pkgver=7.0.110
pkgrel=0
_gittag=v$pkgver
_giturl="https://github.com/dotnet/installer"
@@ -44,8 +52,7 @@ pkgdesc="The .NET $_pkgver_macro bootstrap"
# x86: blocked by https://github.com/dotnet/runtime/issues/77667
# armhf: blocked by https://github.com/dotnet/runtime/issues/77663
# riscv64: port WIP https://github.com/dotnet/runtime/issues/36748
-# s390x | ppc64le: no diskspace / lack maintainer resources
-arch="x86_64 armv7 aarch64"
+arch="all !x86 !armhf !riscv64"
url=https://dotnet.microsoft.com
license="MIT"
# hack for dotnetx-build to be able to pull itself for bootstrapping
@@ -534,7 +541,7 @@ doc() {
}
sha512sums="
-100e6d2057475d0f493a120f916d266b13aca48feb988c13d8f68557f61bf09237561b68dee514d3899b2c0e817aa12dae22ebf08f93a89dc85a2f64d2ebc159 dotnet-v7.0.108.tar.xz
+806bc8467dd23bb07d80afea00ec7973040302c509e544121bb26a308a3cc1e861a34b784d02f9ecf218acbb46fa32679c8fa56c86c04f58767c530a3592aeb6 dotnet-v7.0.110.tar.xz
e9f3df13d093fac214778c1137857e065f58d4e0d2a48d540d8ed7bb41e2fd73b2b3f62a0aa5b0e80fa80a5b58ba77ff19b9d10a492802f8539e3a6ed79d299d dotnet-testsuite-e1cc0f181ffd4d755756d30d985513897d592ba4.tar.gz
0028d5d97b814b122d73137b4e0d64ca5d788aa0ae5fde500de722e23522827f2538f06e75acb17cc39b8917961ee78d1f0bbc84b2b624ae0e9bf88adca2ba6f dotnet-bunny-v12.tar.gz
429033f5f6a8e33eb849c29c1d6628faca13751e1b1e536179b491041034dcdee107cbff12f7e9f1ef68a178a0818c534113f63bc8bbc37de67ec900c23cacf4 build_disable-package-validation.patch
@@ -543,7 +550,7 @@ ebab0364deab5d99131e2724b7fbac668bc27ddf74958623af1913e49850df98b2d077d27324b2bb
4ac92d2d9190a55ee20d3e145a28a6953c98d3eb838c8acfb808b8839316443cb64da4a2c5787df0171fce7ef96ff6381043085ed90c23ec09ce9ac81571e675 roslyn-analyzer_disable-apphost.patch
7a3291a05c94986d631a37870f573aca8603e9464cb632b3e5b93eca8a358fc7dcc98a8a8017f566885ceafe462bec734b7d31c7a974270e83c6d2ae54f51902 runtime_76500-mono-musl-support.patch
d732df247c721c9f677baabdd7f36dbf4b564814ff64164361065bb1c196b767494a1d39f634eadf01a23032c7b3e64102614b7213065c81096bbf3f8022e6a0 runtime_82269-mono-thread-coop-undefine-fortify-source.patch
-1f7be536c4826638853f110ee88bbd554be015cc88c6491c1066830789be18ad324f8ed2b1b75ed7aad74457dcafc812730059cb25d36d6344bfae8a517c00c4 runtime_enable-runtime-marshalling.diff
+741d210b83d4dfca79338def253c82737b6d5f319052173f37aa6dfb5b8e90bfc29272657301095a9623ae2c72449ed6fc60cc6c70fcf88f15c66f89cbd3c201 runtime_enable-runtime-marshalling.diff
293742ab307bef459a21deadcc4ad7c7996cc4b490910a36c2763b8ad25cc8a91c4e03b6290567cd1030f69638d0156c5b6970887858fb091f8482b67356065d runtime_enable-system-libunwind.diff
d972e77df27748a80c9b23eca12f9fbd78be97f9034b79cc5703ba58eb6750171d9a115314300f883620ccbca89c65a99ca7a45d54a421b028b590190b4bed80 runtime_remove-usage-of-off64-t.patch
d1b4ebcbb1a6815fc0ce4c471485c232618e60968a879309fb8336821a9351d2e0028d9f7726c0c041c750b497a0baa47400c78c9ceff550b91b4a6c2816fc41 sdk_14239-add-zsh-compdef-completion-script.patch
diff --git a/community/dotnet7-build/runtime_enable-runtime-marshalling.diff b/community/dotnet7-build/runtime_enable-runtime-marshalling.diff
index f609cfa..6b2d9d6 100644
--- a/community/dotnet7-build/runtime_enable-runtime-marshalling.diff
+++ b/community/dotnet7-build/runtime_enable-runtime-marshalling.diff
@@ -1581,7 +1581,7 @@ index 59d139c7749..a8e94e72847 100644
$(NoWarn);SYSLIB0021
diff --git a/src/runtime/src/libraries/System.Security.Cryptography.Pkcs/src/System.Security.Cryptography.Pkcs.csproj b/src/runtime/src/libraries/System.Security.Cryptography.Pkcs/src/System.Security.Cryptography.Pkcs.csproj
-index be33237e616..426ddb38e27 100644
+index d94830c..5840638 100644
--- a/src/runtime/src/libraries/System.Security.Cryptography.Pkcs/src/System.Security.Cryptography.Pkcs.csproj
+++ b/src/runtime/src/libraries/System.Security.Cryptography.Pkcs/src/System.Security.Cryptography.Pkcs.csproj
@@ -1,6 +1,6 @@
@@ -1589,9 +1589,9 @@ index be33237e616..426ddb38e27 100644
- $(NetCoreAppCurrent)-windows;$(NetCoreAppCurrent);$(NetCoreAppMinimum)-windows;$(NetCoreAppMinimum);netstandard2.1;netstandard2.0;$(NetFrameworkMinimum)
+ $(NetCoreAppCurrent);$(NetCoreAppMinimum);netstandard2.1;netstandard2.0;$(NetFrameworkMinimum)
+ $(DefineConstants);BUILDING_PKCS
true
true
- $(NoWarn);CA5384
diff --git a/src/runtime/src/libraries/System.Security.Cryptography.Pkcs/tests/System.Security.Cryptography.Pkcs.Tests.csproj b/src/runtime/src/libraries/System.Security.Cryptography.Pkcs/tests/System.Security.Cryptography.Pkcs.Tests.csproj
index 8523c0d8296..2045f05a28e 100644
--- a/src/runtime/src/libraries/System.Security.Cryptography.Pkcs/tests/System.Security.Cryptography.Pkcs.Tests.csproj
@@ -1805,3 +1805,4 @@ index e7b45293318..089fe0ef33f 100644
--
2.36.3
+