community/git-annex: upgrade for edge
This commit is contained in:
parent
dbca3a622d
commit
d6337b4ceb
3 changed files with 16 additions and 25 deletions
|
@ -59,7 +59,7 @@ cabal_update() {
|
||||||
|
|
||||||
# Resolve deps and generate fresh cabal.config with version constraints.
|
# Resolve deps and generate fresh cabal.config with version constraints.
|
||||||
HOME="$_cabal_home" cabal update
|
HOME="$_cabal_home" cabal update
|
||||||
cd "$builddir"
|
cd "$srcdir/git-annex"*
|
||||||
HOME="$_cabal_home" cabal v1-freeze --shadow-installed-packages
|
HOME="$_cabal_home" cabal v1-freeze --shadow-installed-packages
|
||||||
|
|
||||||
# Add version tag at the first line.
|
# Add version tag at the first line.
|
||||||
|
@ -115,7 +115,7 @@ package() {
|
||||||
|
|
||||||
sha512sums="
|
sha512sums="
|
||||||
a25e57f0cb632934c521ab34dd2b71bf3c98de768b817cb6fc4af76fb00ea281bb0f1e9a33f347ed69ddded71018562ac8061debd7189d12d067408cec5282b5 git-annex-10.20230828.tar.gz
|
a25e57f0cb632934c521ab34dd2b71bf3c98de768b817cb6fc4af76fb00ea281bb0f1e9a33f347ed69ddded71018562ac8061debd7189d12d067408cec5282b5 git-annex-10.20230828.tar.gz
|
||||||
e0fd71ebdf7d3a0f3894e296fd4ede4f2f7ce6e2ef1133fdc09c37d86b19403d65077c2cf883673f72fa75383d4422c2c7a4c55e586a788d68336797af8c6c16 git-annex.config
|
f5d535f9012dd3a67d61b8404883154cfebeb0d36a98f63c65896326b6a3893678c81926535afa0e862498a7ec11ee0b65be5e004aa93506b87d74995f4f9ae1 git-annex.config
|
||||||
700e561b79e186839dfb8c63b185ce5f83745f8c43473e0fd99df3cdae2165073a8fe4b1cfb2798b3ad852e22e3eea84a05b884ef10b89f80f9881e0921aab2f git-annex-block-crypton.patch
|
700e561b79e186839dfb8c63b185ce5f83745f8c43473e0fd99df3cdae2165073a8fe4b1cfb2798b3ad852e22e3eea84a05b884ef10b89f80f9881e0921aab2f git-annex-block-crypton.patch
|
||||||
178be26bc808f6a5c065957b04e3a32b02f0a6b5eb8c422c9d8960b6e9a1f90d689360c5ad491156783b25e80f4c2f9861e9ccff5091c302be713fa3063df670 fix-makefile.patch
|
9300f883746d8726f47be6d194b5ac9550e2894669097f3202eca944221665bd3087a81b3f97b21f013eccaa6b5b1fb050e253ac18999c136db20056fadf2ed8 fix-makefile.patch
|
||||||
"
|
"
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 437afb7ee2a..c471026dede 100644
|
index 5688430..54fe3c8 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -85,24 +85,24 @@ install-docs: docs install-mans
|
@@ -87,16 +87,16 @@ install-docs: docs install-mans
|
||||||
rsync -a --delete html/ $(DESTDIR)$(PREFIX)/$(SHAREDIR)/doc/git-annex/html/; \
|
rsync -a --delete html/ $(DESTDIR)$(PREFIX)/$(SHAREDIR)/doc/git-annex/html/; \
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
@ -22,13 +22,3 @@ index 437afb7ee2a..c471026dede 100644
|
||||||
install -d $(DESTDIR)$(PREFIX)/$(SHAREDIR)/bash-completion/completions
|
install -d $(DESTDIR)$(PREFIX)/$(SHAREDIR)/bash-completion/completions
|
||||||
install -m 0644 bash-completion.bash $(DESTDIR)$(PREFIX)/$(SHAREDIR)/bash-completion/completions/git-annex
|
install -m 0644 bash-completion.bash $(DESTDIR)$(PREFIX)/$(SHAREDIR)/bash-completion/completions/git-annex
|
||||||
install -d $(DESTDIR)$(ZSH_COMPLETIONS_PATH)
|
install -d $(DESTDIR)$(ZSH_COMPLETIONS_PATH)
|
||||||
./git-annex --zsh-completion-script git-annex 2>/dev/null \
|
|
||||||
> $(DESTDIR)$(ZSH_COMPLETIONS_PATH)/_git-annex
|
|
||||||
- install -d $(DESTDIR)$(PREFIX)/$(SHAREDIR)/fish/vendor_completions.d
|
|
||||||
+ install -d $(DESTDIR)$(PREFIX)/$(SHAREDIR)/fish/completions
|
|
||||||
./git-annex --fish-completion-script git-annex 2>/dev/null \
|
|
||||||
- > $(DESTDIR)$(PREFIX)/$(SHAREDIR)/fish/vendor_completions.d/git-annex.fish
|
|
||||||
+ > $(DESTDIR)$(PREFIX)/$(SHAREDIR)/fish/completions/git-annex.fish
|
|
||||||
|
|
||||||
test: git-annex git-annex-shell
|
|
||||||
./git-annex test
|
|
||||||
|
|
|
@ -24,10 +24,9 @@ constraints: Cabal ==3.8.1.0,
|
||||||
async ==2.2.4,
|
async ==2.2.4,
|
||||||
attoparsec ==0.14.4,
|
attoparsec ==0.14.4,
|
||||||
attoparsec-aeson ==2.1.0.0,
|
attoparsec-aeson ==2.1.0.0,
|
||||||
attoparsec-iso8601 ==1.1.0.0,
|
|
||||||
auto-update ==0.1.6,
|
auto-update ==0.1.6,
|
||||||
aws ==0.24.1,
|
aws ==0.24.1,
|
||||||
base ==4.17.0.0,
|
base ==4.17.2.0,
|
||||||
base-compat ==0.13.0,
|
base-compat ==0.13.0,
|
||||||
base-compat-batteries ==0.13.0,
|
base-compat-batteries ==0.13.0,
|
||||||
base-orphans ==0.9.0,
|
base-orphans ==0.9.0,
|
||||||
|
@ -46,7 +45,7 @@ constraints: Cabal ==3.8.1.0,
|
||||||
bsb-http-chunked ==0.0.0.4,
|
bsb-http-chunked ==0.0.0.4,
|
||||||
byteable ==0.1.1,
|
byteable ==0.1.1,
|
||||||
byteorder ==1.0.4,
|
byteorder ==1.0.4,
|
||||||
bytestring ==0.11.3.1,
|
bytestring ==0.11.5.1,
|
||||||
cabal-doctest ==1.0.9,
|
cabal-doctest ==1.0.9,
|
||||||
call-stack ==0.4.0,
|
call-stack ==0.4.0,
|
||||||
case-insensitive ==1.2.1.0,
|
case-insensitive ==1.2.1.0,
|
||||||
|
@ -61,7 +60,7 @@ constraints: Cabal ==3.8.1.0,
|
||||||
conduit ==1.3.5,
|
conduit ==1.3.5,
|
||||||
conduit-extra ==1.3.6,
|
conduit-extra ==1.3.6,
|
||||||
connection ==0.3.1,
|
connection ==0.3.1,
|
||||||
containers ==0.6.6,
|
containers ==0.6.7,
|
||||||
contravariant ==1.5.5,
|
contravariant ==1.5.5,
|
||||||
cookie ==0.4.6,
|
cookie ==0.4.6,
|
||||||
criterion ==1.6.3.0,
|
criterion ==1.6.3.0,
|
||||||
|
@ -100,8 +99,8 @@ constraints: Cabal ==3.8.1.0,
|
||||||
free ==5.2,
|
free ==5.2,
|
||||||
generically ==0.1.1,
|
generically ==0.1.1,
|
||||||
ghc-bignum ==1.3,
|
ghc-bignum ==1.3,
|
||||||
ghc-boot-th ==9.4.4,
|
ghc-boot-th ==9.4.6,
|
||||||
ghc-prim ==0.9.0,
|
ghc-prim ==0.9.1,
|
||||||
git-lfs ==1.2.1,
|
git-lfs ==1.2.1,
|
||||||
happy ==1.20.1.1,
|
happy ==1.20.1.1,
|
||||||
hashable ==1.4.3.0,
|
hashable ==1.4.3.0,
|
||||||
|
@ -110,7 +109,7 @@ constraints: Cabal ==3.8.1.0,
|
||||||
hjsmin ==0.2.1,
|
hjsmin ==0.2.1,
|
||||||
hourglass ==0.2.12,
|
hourglass ==0.2.12,
|
||||||
hsc2hs ==0.68.9,
|
hsc2hs ==0.68.9,
|
||||||
http-api-data ==0.5.1,
|
http-api-data ==0.6,
|
||||||
http-client ==0.7.14,
|
http-client ==0.7.14,
|
||||||
http-client-restricted ==0.0.5,
|
http-client-restricted ==0.0.5,
|
||||||
http-client-tls ==0.3.6.1,
|
http-client-tls ==0.3.6.1,
|
||||||
|
@ -120,6 +119,7 @@ constraints: Cabal ==3.8.1.0,
|
||||||
http2 ==4.1.4,
|
http2 ==4.1.4,
|
||||||
indexed-traversable ==0.1.2.1,
|
indexed-traversable ==0.1.2.1,
|
||||||
indexed-traversable-instances ==0.1.1.2,
|
indexed-traversable-instances ==0.1.1.2,
|
||||||
|
integer-conversion ==0.1,
|
||||||
integer-gmp ==1.1,
|
integer-gmp ==1.1,
|
||||||
integer-logarithms ==1.0.3.1,
|
integer-logarithms ==1.0.3.1,
|
||||||
invariant ==0.6.2,
|
invariant ==0.6.2,
|
||||||
|
@ -155,7 +155,7 @@ constraints: Cabal ==3.8.1.0,
|
||||||
old-time ==1.1.0.3,
|
old-time ==1.1.0.3,
|
||||||
optparse-applicative ==0.18.1.0,
|
optparse-applicative ==0.18.1.0,
|
||||||
parallel ==3.2.2.0,
|
parallel ==3.2.2.0,
|
||||||
parsec ==3.1.15.0,
|
parsec ==3.1.16.1,
|
||||||
path-pieces ==0.2.1,
|
path-pieces ==0.2.1,
|
||||||
pem ==0.2.4,
|
pem ==0.2.4,
|
||||||
persistent ==2.14.5.1,
|
persistent ==2.14.5.1,
|
||||||
|
@ -165,7 +165,7 @@ constraints: Cabal ==3.8.1.0,
|
||||||
prettyprinter ==1.7.1,
|
prettyprinter ==1.7.1,
|
||||||
prettyprinter-ansi-terminal ==1.1.3,
|
prettyprinter-ansi-terminal ==1.1.3,
|
||||||
primitive ==0.8.0.0,
|
primitive ==0.8.0.0,
|
||||||
process ==1.6.16.0,
|
process ==1.6.17.0,
|
||||||
profunctors ==5.6.2,
|
profunctors ==5.6.2,
|
||||||
psqueues ==0.2.7.3,
|
psqueues ==0.2.7.3,
|
||||||
random ==1.2.1.1,
|
random ==1.2.1.1,
|
||||||
|
@ -207,7 +207,8 @@ constraints: Cabal ==3.8.1.0,
|
||||||
template-haskell ==2.19.0.0,
|
template-haskell ==2.19.0.0,
|
||||||
terminal-size ==0.3.4,
|
terminal-size ==0.3.4,
|
||||||
terminfo ==0.4.1.5,
|
terminfo ==0.4.1.5,
|
||||||
text ==2.0.1,
|
text ==2.0.2,
|
||||||
|
text-iso8601 ==0.1,
|
||||||
text-short ==0.1.5,
|
text-short ==0.1.5,
|
||||||
th-abstraction ==0.5.0.0,
|
th-abstraction ==0.5.0.0,
|
||||||
th-compat ==0.1.4,
|
th-compat ==0.1.4,
|
||||||
|
|
Loading…
Reference in a new issue