backports/cargo-auditable: new aport
This commit is contained in:
parent
36564d7f54
commit
d3b220644d
2 changed files with 55 additions and 0 deletions
42
backports/cargo-auditable/APKBUILD
Normal file
42
backports/cargo-auditable/APKBUILD
Normal file
|
@ -0,0 +1,42 @@
|
|||
# Maintainer: psykose <alice@ayaya.dev>
|
||||
pkgname=cargo-auditable
|
||||
pkgver=0.6.1
|
||||
pkgrel=1
|
||||
pkgdesc="Cargo wrapper for embedding auditing data"
|
||||
url="https://github.com/rust-secure-code/cargo-auditable"
|
||||
arch="!armv7 all"
|
||||
license="MIT OR Apache-2.0"
|
||||
makedepends="cargo"
|
||||
subpackages="$pkgname-doc"
|
||||
source="$pkgname-$pkgver.tar.gz::https://github.com/rust-secure-code/cargo-auditable/archive/refs/tags/v$pkgver.tar.gz
|
||||
lock.patch
|
||||
"
|
||||
options="net"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
|
||||
cargo fetch --target="$CTARGET" --locked
|
||||
}
|
||||
|
||||
build() {
|
||||
msg "building cargo auditable"
|
||||
cargo build --release --frozen
|
||||
msg "rebuilding with cargo-auditable itself"
|
||||
PATH="$PATH:$PWD/target/release" \
|
||||
cargo auditable build --release --frozen
|
||||
}
|
||||
|
||||
check() {
|
||||
cargo test --frozen
|
||||
}
|
||||
|
||||
package() {
|
||||
install -Dm755 target/release/cargo-auditable -t "$pkgdir"/usr/bin/
|
||||
install -Dm644 cargo-auditable/cargo-auditable.1 -t "$pkgdir"/usr/share/man/man1/
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
191b6ef15436bd3c6a9b4666e80de5a085afe00f8ee3793040fc5e5f78eecc25d45e556fe8279b600f362b46cbecae6c6f7e21060ea0d2344f459817749f4616 cargo-auditable-0.6.1.tar.gz
|
||||
9fa1b61897559fd9d4da8c43fa69b76b04f9a4dfedeb1973b096948e7684b16c2142bada7f7d2e8f9aa80e483b40aa662c45f6eaa87d3fa213d1e53816e9aaad lock.patch
|
||||
"
|
13
backports/cargo-auditable/lock.patch
Normal file
13
backports/cargo-auditable/lock.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/Cargo.lock b/Cargo.lock
|
||||
index 00969c9..5caabbd 100644
|
||||
--- a/Cargo.lock
|
||||
+++ b/Cargo.lock
|
||||
@@ -72,7 +72,7 @@ dependencies = [
|
||||
|
||||
[[package]]
|
||||
name = "cargo-auditable"
|
||||
-version = "0.6.0"
|
||||
+version = "0.6.1"
|
||||
dependencies = [
|
||||
"auditable-info",
|
||||
"auditable-serde",
|
Loading…
Reference in a new issue