mumble-web-proxy
All checks were successful
All checks were successful
This commit is contained in:
parent
269dc4f118
commit
d2b57c37fc
3 changed files with 15 additions and 26 deletions
|
@ -12,6 +12,7 @@ source="
|
|||
$pkgname-$_gittag.tar.gz::https://github.com/Johni0702/mumble-web-proxy/archive/$_gittag.tar.gz
|
||||
mumble-web-proxy.initd
|
||||
mumble-web-proxy.conf
|
||||
fix-build.patch
|
||||
"
|
||||
builddir="$srcdir"/$pkgname-$_gittag
|
||||
options="!check"
|
||||
|
@ -30,4 +31,5 @@ sha512sums="
|
|||
c6b0aa5d355f90b4d57d3935b696f7a00421b9347f59e451bcc3c5fa8c1bcf28e328e109b17cbbfdea4430e7b52dfdf785ea188c77efc0c0727b20a045fb95ab mumble-web-proxy-21bd9dc06509b045722b1e4edc14115c739d3f24.tar.gz
|
||||
ab470bd12df5a3c9b5d2526c27f8a7e2dc437fc2bfb943b9e98c975d87b2bfa5e7e906001cb66c6c26e505df17a5d335a556b52f534e973ef6b49b14b26468a5 mumble-web-proxy.initd
|
||||
bbb197930295448c4cbb59b0ba9fbae75d5d2bd0868c96327840b00a69c7755831080a771d487348fe204d09636a95947aaea5d83714126032a38f8a5fce8bd3 mumble-web-proxy.conf
|
||||
4520a3a745d2456f089bee2a6efc1a60e9f350765c059695806a83c68529e6d466d0756d26fc114a6fc4e8cd57e9f458704a53f0a69afa1edaf22e5176c66e82 fix-build.patch
|
||||
"
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
Compiling tokio-tungstenite v0.13.0
|
||||
error[E0282]: type annotations needed
|
||||
--> /var/build/build/apk/v3.15/main/mumble-web-proxy/src/mumble-web-proxy/cargo/git/checkouts/rtp-23e67d7854ed482f/6c0223d/src/rfc3711.rs:477:19
|
||||
|
|
||||
476 | let iv = iv ^ (BigUint::from(1_u8) << (context.session_encr_key.len() * 8));
|
||||
| -- consider giving `iv` a type
|
||||
477 | let iv = &iv.to_bytes_be()[1..context.session_encr_key.len() + 1];
|
||||
| ^^ cannot infer type
|
||||
|
|
||||
= note: type must be known at this point
|
||||
|
||||
error[E0282]: type annotations needed
|
||||
--> /var/build/build/apk/v3.15/main/mumble-web-proxy/src/mumble-web-proxy/cargo/git/checkouts/rtp-23e67d7854ed482f/6c0223d/src/rfc3711.rs:511:19
|
||||
|
|
||||
510 | let iv = iv ^ (BigUint::from(1_u8) << (context.session_encr_key.len() * 8));
|
||||
| -- consider giving `iv` a type
|
||||
511 | let iv = &iv.to_bytes_be()[1..context.session_encr_key.len() + 1];
|
||||
| ^^ cannot infer type
|
||||
|
|
||||
= note: type must be known at this point
|
||||
|
||||
For more information about this error, try `rustc --explain E0282`.
|
||||
error: could not compile `rtp` due to 2 previous errors
|
||||
warning: build failed, waiting for other jobs to finish...
|
||||
error: build failed
|
||||
|
13
user/mumble-web-proxy/fix-build.patch
Normal file
13
user/mumble-web-proxy/fix-build.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/Cargo.toml.orig b/Cargo.toml
|
||||
index 83d4c95..e2834af 100644
|
||||
--- a/Cargo.toml.orig
|
||||
+++ b/Cargo.toml
|
||||
@@ -19,7 +19,7 @@ mumble-protocol = { version = "0.4", features = ["webrtc-extensions"] }
|
||||
tokio-tungstenite = "0.13"
|
||||
http = "0.2"
|
||||
tungstenite = "0.12"
|
||||
-rtp = { git = "https://github.com/johni0702/rtp", rev = "6c0223d", features = ["rfc5764-openssl"] }
|
||||
+rtp = { git = "https://github.com/Skgland/rtp", rev = "83eb4dd", features = ["rfc5764-openssl"] }
|
||||
libnice = "0.3"
|
||||
webrtc-sdp = "0.3"
|
||||
openssl = "0.10"
|
Loading…
Reference in a new issue