backports/py3-utils: new aport

This commit is contained in:
Antoine Martin 2024-01-18 15:07:55 -05:00
parent a7ec354240
commit c80c39ddb0
Signed by: forge
GPG key ID: D62A472A4AA7D541
2 changed files with 52 additions and 0 deletions

View file

@ -0,0 +1,38 @@
# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=py3-utils
_pkgname=python-utils
pkgver=3.5.2
pkgrel=1
pkgdesc="Convenient utilities not included with the standard Python install"
url="https://github.com/WoLpH/python-utils"
arch="noarch !s390x" # fails tests
license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pytest-asyncio py3-loguru"
subpackages="$pkgname-pyc"
source="
https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
pytest.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
python3 setup.py build
}
check() {
pytest
}
package() {
python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
2e36bbb2e43591744c63ea972b7f361138694eb32510643ea88e8d757882379e3aec247c2fc4d5c67876939b71d564570a975700728c79f9db0cc4fcbc1605e7 python-utils-3.5.2.tar.gz
8eb5c8a924e4251744e61f7a662496fb5c65d965b1e11596314ac2b72d6643a5496cf264a24ef93732bef1e7cc88ba0794eaf344477704486af75d2930ecb0f9 pytest.patch
"

View file

@ -0,0 +1,14 @@
diff --git a/pytest.ini b/pytest.ini
index 5d49701..e28ed7d 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -5,9 +5,6 @@ python_files =
addopts =
--doctest-modules
- --cov python_utils
- --cov-report term-missing
- --mypy
doctest_optionflags =
ALLOW_UNICODE