user/mumble-web-proxy: move from unmaintained, fix build

This commit is contained in:
Antoine Martin 2024-12-27 21:58:45 -05:00
parent d9e1d9a75a
commit a0a71388b1
Signed by: forge
GPG key ID: D62A472A4AA7D541
6 changed files with 48 additions and 77 deletions

View file

@ -1,51 +0,0 @@
# Maintainer: Edouard Lafon <dev+arch@elafon.98.wf>
pkgname=mumble-web-proxy
pkgver=0.1.1
pkgrel=1
pkgdesc="mumble-web-proxy is a Mumble to WebSocket+WebRTC proxy"
arch='x86_64'
url="https://github.com/johni0702/mumble-web-proxy"
license='AGLP-3.0'
makedepends='rustup libnice-dev openssl-dev clang cargo'
source="$pkgname-$pkgver.tar.gz mumble-web-proxy.initd mumble-web-proxy.conf"
_giturl="https://github.com/johni0702/mumble-web-proxy"
_gittag="cfae6178c70c1436186f16723b18a2cbb0f06138"
builddir="$srcdir/$pkgname"
options="!check"
subpackages="${pkgname}-openrc"
snapshot() {
mkdir -p "$srcdir"
cd "${srcdir}"
if ! [ -d $pkgname.git ]; then
git clone $_giturl $pkgname.git || return 1
cd $pkgname.git
else
cd $pkgname.git
git fetch || return 1
fi
echo "Checking out"
git checkout $_gittag
echo "Repo archive"
git archive --prefix="$pkgname/" -o $pkgname.tar --format "tar" $_gittag
gzip $pkgname.tar -c > "$SRCDEST"/$pkgname-$pkgver.tar.gz
ln -s "$SRCDEST"/$pkgname-$pkgver.tar.gz "$startdir"/$pkgname-$pkgver.tar.gz
}
build() {
cd $builddir
export CARGO_HOME="$builddir"/cargo
cargo build --release
}
package() {
install -Dm755 "${builddir}"/target/release/mumble-web-proxy "${pkgdir}"/usr/bin/mumble-web-proxy
install -Dm755 "${srcdir}"/mumble-web-proxy.initd "${pkgdir}"/etc/init.d/mumble-web-proxy
install -Dm644 "${srcdir}"/mumble-web-proxy.conf "${pkgdir}"/etc/mumble-web-proxy.conf
}
sha512sums="08d522fdc625c231b7f931bdb3c788f4c5dabf0ed14a3d76b9bd0e0cb56f8fce0fb72f531670b3004f9105650c36ed15386c2677753c355bbe76e7a56a3ce8b5 mumble-web-proxy-0.1.1.tar.gz
ab470bd12df5a3c9b5d2526c27f8a7e2dc437fc2bfb943b9e98c975d87b2bfa5e7e906001cb66c6c26e505df17a5d335a556b52f534e973ef6b49b14b26468a5 mumble-web-proxy.initd
bbb197930295448c4cbb59b0ba9fbae75d5d2bd0868c96327840b00a69c7755831080a771d487348fe204d09636a95947aaea5d83714126032a38f8a5fce8bd3 mumble-web-proxy.conf"

View file

@ -1,26 +0,0 @@
Compiling tokio-tungstenite v0.13.0
error[E0282]: type annotations needed
--> /var/build/build/apk/v3.15/main/mumble-web-proxy/src/mumble-web-proxy/cargo/git/checkouts/rtp-23e67d7854ed482f/6c0223d/src/rfc3711.rs:477:19
|
476 | let iv = iv ^ (BigUint::from(1_u8) << (context.session_encr_key.len() * 8));
| -- consider giving `iv` a type
477 | let iv = &iv.to_bytes_be()[1..context.session_encr_key.len() + 1];
| ^^ cannot infer type
|
= note: type must be known at this point
error[E0282]: type annotations needed
--> /var/build/build/apk/v3.15/main/mumble-web-proxy/src/mumble-web-proxy/cargo/git/checkouts/rtp-23e67d7854ed482f/6c0223d/src/rfc3711.rs:511:19
|
510 | let iv = iv ^ (BigUint::from(1_u8) << (context.session_encr_key.len() * 8));
| -- consider giving `iv` a type
511 | let iv = &iv.to_bytes_be()[1..context.session_encr_key.len() + 1];
| ^^ cannot infer type
|
= note: type must be known at this point
For more information about this error, try `rustc --explain E0282`.
error: could not compile `rtp` due to 2 previous errors
warning: build failed, waiting for other jobs to finish...
error: build failed

View file

@ -0,0 +1,35 @@
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=mumble-web-proxy
pkgver=0.1.1
_gittag=21bd9dc06509b045722b1e4edc14115c739d3f24
pkgrel=1
pkgdesc="mumble-web-proxy is a Mumble to WebSocket+WebRTC proxy"
arch='x86_64'
url="https://github.com/johni0702/mumble-web-proxy"
license='AGPL-3.0'
makedepends='rustup libnice-dev openssl-dev clang cargo'
source="
$pkgname-$_gittag.tar.gz::https://github.com/Johni0702/mumble-web-proxy/archive/$_gittag.tar.gz
mumble-web-proxy.initd
mumble-web-proxy.conf
fix-build.patch
"
builddir="$srcdir"/$pkgname-$_gittag
options="!check"
subpackages="$pkgname-openrc"
build() {
CARGO_HOME="$builddir"/cargo cargo build --release
}
package() {
install -Dm755 "$builddir"/target/release/mumble-web-proxy "$pkgdir"/usr/bin/mumble-web-proxy
install -Dm755 "$srcdir"/mumble-web-proxy.initd "$pkgdir"/etc/init.d/mumble-web-proxy
install -Dm644 "$srcdir"/mumble-web-proxy.conf "$pkgdir"/etc/mumble-web-proxy.conf
}
sha512sums="
c6b0aa5d355f90b4d57d3935b696f7a00421b9347f59e451bcc3c5fa8c1bcf28e328e109b17cbbfdea4430e7b52dfdf785ea188c77efc0c0727b20a045fb95ab mumble-web-proxy-21bd9dc06509b045722b1e4edc14115c739d3f24.tar.gz
ab470bd12df5a3c9b5d2526c27f8a7e2dc437fc2bfb943b9e98c975d87b2bfa5e7e906001cb66c6c26e505df17a5d335a556b52f534e973ef6b49b14b26468a5 mumble-web-proxy.initd
bbb197930295448c4cbb59b0ba9fbae75d5d2bd0868c96327840b00a69c7755831080a771d487348fe204d09636a95947aaea5d83714126032a38f8a5fce8bd3 mumble-web-proxy.conf
4520a3a745d2456f089bee2a6efc1a60e9f350765c059695806a83c68529e6d466d0756d26fc114a6fc4e8cd57e9f458704a53f0a69afa1edaf22e5176c66e82 fix-build.patch
"

View file

@ -0,0 +1,13 @@
diff --git a/Cargo.toml.orig b/Cargo.toml
index 83d4c95..e2834af 100644
--- a/Cargo.toml.orig
+++ b/Cargo.toml
@@ -19,7 +19,7 @@ mumble-protocol = { version = "0.4", features = ["webrtc-extensions"] }
tokio-tungstenite = "0.13"
http = "0.2"
tungstenite = "0.12"
-rtp = { git = "https://github.com/johni0702/rtp", rev = "6c0223d", features = ["rfc5764-openssl"] }
+rtp = { git = "https://github.com/Skgland/rtp", rev = "83eb4dd", features = ["rfc5764-openssl"] }
libnice = "0.3"
webrtc-sdp = "0.3"
openssl = "0.10"