[86;1R[86;1R[86;1R[86;1R[86;1gommits.

user/kb: new aport
This commit is contained in:
Antoine Martin 2024-01-12 16:30:12 -05:00
parent 9a7604eaad
commit 7916377e65
2 changed files with 49 additions and 0 deletions

38
user/kb/APKBUILD Normal file
View file

@ -0,0 +1,38 @@
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=kb
_pkgreal=kb-manager
pkgver=0.1.7
pkgrel=0
pkgdesc="A command line minimalist knowledge base manager"
arch="noarch"
url="https://github.com/gnebbia/kb"
license="GPL-3.0-only"
depends="py3-attrs py3-colored py3-gitpython"
makedepends="py3-setuptools py3-gpep517 py3-wheel"
checkdepends="py3-toml py3-pytest-cov"
source="
https://files.pythonhosted.org/packages/source/k/kb-manager/kb-manager-$pkgver.tar.gz
python-colored.patch
"
subpackages="$pkgname-pyc"
builddir="$srcdir"/$_pkgreal-$pkgver
build() {
gpep517 build-wheel \
--wheel-dir .dist \
--output-fd 3 3>&1 >&2
}
check() {
pytest -v
}
package() {
python3 -m installer -d "$pkgdir" \
.dist/*.whl
}
sha512sums="
f0dff69a5e95339ea22d0a9d1260473f7b0b6ace184936896e164172aecb77672e9e0a228159abc95e50f30de2ec9ca5185ffbd825dce87edfec267bc56c75dc kb-manager-0.1.7.tar.gz
efb593959c790fc57822820a3ac2936dc90543e88268a9a47aa7248b6f1875e45d1ee7dbecac47b717491810483367b29670e0661ebbb760f875acb2e48b8765 python-colored.patch
"

View file

@ -0,0 +1,11 @@
diff --git a/kb/printer/style.py b/kb/printer/style.py
index e0fd752..2bc7bf5 100644
--- a/kb/printer/style.py
+++ b/kb/printer/style.py
@@ -17,5 +17,5 @@ from kb.entities.artifact import Artifact
ALT_BGROUND = styler.set_bg('#303030')
BOLD = styler.set_style('bold')
-UND = styler.set_style('underlined')
+UND = styler.set_style('underline')
RESET = styler.reset()