backports/py3-daemon: remove docutils depend

This commit is contained in:
Antoine Martin 2024-06-02 19:11:26 -04:00
parent de61d62ece
commit 78a43bb4de
2 changed files with 22 additions and 2 deletions

View file

@ -2,7 +2,7 @@
# Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
pkgname=py3-daemon
pkgver=2.3.2
pkgrel=2
pkgrel=4
pkgdesc="Library to implement a well-behaved Unix daemon process"
url="https://pagure.io/python-daemon"
options="!check" # Has lots of dependencies
@ -11,7 +11,10 @@ license="Apache-2.0 AND GPL-3.0-or-later"
depends="py3-setuptools py3-lockfile"
makedepends="py3-docutils"
subpackages="$pkgname-pyc"
source="https://pypi.io/packages/source/p/python-daemon/python-daemon-$pkgver.tar.gz"
source="
https://pypi.io/packages/source/p/python-daemon/python-daemon-$pkgver.tar.gz
remove-docutils-depend.patch
"
builddir="$srcdir/python-daemon-$pkgver"
prepare() {
@ -33,4 +36,5 @@ package() {
sha512sums="
d9f6e6c376a496fae96bd9efed0a56d00a137617a3d1d5ef74802ef176bc813bb1d49bbb9164cdbec03213529f944b32b257bcc64283abfa4a3522ff00826bfd python-daemon-2.3.2.tar.gz
20bc4bce7fba9754d1c9bca298f9b4ff7fe90ecf51769df2020912f370650a5997f91c99c6be2ecffed10a6b359a29b1f64b0c391772451eb3c04769df381015 remove-docutils-depend.patch
"

View file

@ -0,0 +1,16 @@
diff --git a/setup.py.orig b/setup.py
index 24f0e7cb98a..d712294c20b 100644
--- a/setup.py.orig
+++ b/setup.py
@@ -96,11 +96,6 @@ setup_kwargs = dict(
],
)
-# Docutils is only required for building, but Setuptools can't distinguish
-# dependencies properly.
-# See <URL:https://github.com/pypa/setuptools/issues/457>.
-setup_kwargs['install_requires'].append("docutils")
-
if __name__ == '__main__':
setup(**setup_kwargs)