user/papermc-plugin-vault: new aport
This commit is contained in:
parent
233a098355
commit
77727d2ab0
5 changed files with 184 additions and 0 deletions
Binary file not shown.
|
@ -0,0 +1,33 @@
|
|||
From 2022cb08922caa42aa77faca254c9b7d7506bee8 Mon Sep 17 00:00:00 2001
|
||||
From: Geolykt <admin@geolykt.de>
|
||||
Date: Mon, 27 Jun 2022 12:02:49 +0200
|
||||
Subject: [PATCH] Support newer JDKs for building
|
||||
|
||||
Apparently the ancient version of lombok used
|
||||
by a dependency is not compatible with newer
|
||||
versions of java. As Vault proper did not make
|
||||
use of lombok, it can be safely removed without
|
||||
declaring an alternative.
|
||||
|
||||
This commit allows Vault to build under Java 17.
|
||||
---
|
||||
pom.xml | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 5b8a6dfd..17c189fd 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -324,6 +324,12 @@ Vault currently supports the following: Permissions 3, PEX, GroupManager, bPerms
|
||||
<artifactId>craftconomy3</artifactId>
|
||||
<version>3.2.2-SNAPSHOT</version>
|
||||
<optional>true</optional>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>org.projectlombok</groupId>
|
||||
+ <artifactId>lombok</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>net.crystalyx.bukkit.simplyperms</groupId>
|
|
@ -0,0 +1,37 @@
|
|||
From 52df9d3287e8d593d0e4d999c6d5daaebe947ca1 Mon Sep 17 00:00:00 2001
|
||||
From: Ricardo Boss <mail@ricardoboss.de>
|
||||
Date: Tue, 28 Jun 2022 18:50:18 +0200
|
||||
Subject: [PATCH] Add option to silence "no update" logs (#823)
|
||||
|
||||
* Added "silent-no-update" config option
|
||||
|
||||
Added switch to turn off messages if no update is available.
|
||||
|
||||
* Set default value for "silent-no-update"
|
||||
|
||||
* Removed any "no update available" option and message
|
||||
---
|
||||
src/net/milkbowl/vault/Vault.java | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/src/net/milkbowl/vault/Vault.java b/src/net/milkbowl/vault/Vault.java
|
||||
index ef8b5578..fd2a9787 100644
|
||||
--- a/src/net/milkbowl/vault/Vault.java
|
||||
+++ b/src/net/milkbowl/vault/Vault.java
|
||||
@@ -171,8 +171,6 @@ public void run() {
|
||||
log.warning("Update at: https://dev.bukkit.org/projects/vault");
|
||||
} else if (currentVersion > newVersion) {
|
||||
log.info("Stable Version: " + newVersionTitle + " | Current Version: " + currentVersionTitle);
|
||||
- } else {
|
||||
- log.info("No new version available");
|
||||
}
|
||||
} catch (Exception e) {
|
||||
// ignore exceptions
|
||||
@@ -182,7 +180,6 @@ public void run() {
|
||||
}, 0, 432000);
|
||||
|
||||
}
|
||||
-
|
||||
});
|
||||
|
||||
// Load up the Plugin metrics
|
72
user/papermc-plugin-vault/868_update-bstats.patch
Normal file
72
user/papermc-plugin-vault/868_update-bstats.patch
Normal file
|
@ -0,0 +1,72 @@
|
|||
From 3f20655f0b1b9c7a0f69eb241c5bedd8e748b5c9 Mon Sep 17 00:00:00 2001
|
||||
From: Leonardo Di Gianfelice Stornelli
|
||||
<leonardo.digianfelicestornelli@gmail.com>
|
||||
Date: Tue, 28 Jun 2022 00:34:40 +0200
|
||||
Subject: [PATCH] Update bStats (#868)
|
||||
|
||||
---
|
||||
pom.xml | 2 +-
|
||||
src/net/milkbowl/vault/Vault.java | 9 +++++----
|
||||
2 files changed, 6 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 17c189fd..ccd8cde4 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -85,7 +85,7 @@ Vault currently supports the following: Permissions 3, PEX, GroupManager, bPerms
|
||||
<dependency>
|
||||
<groupId>org.bstats</groupId>
|
||||
<artifactId>bstats-bukkit</artifactId>
|
||||
- <version>1.5</version>
|
||||
+ <version>3.0.0</version>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>com.gmail.bleedobsidian.miconomy</groupId>
|
||||
diff --git a/src/net/milkbowl/vault/Vault.java b/src/net/milkbowl/vault/Vault.java
|
||||
index 30f6f17f..ef8b5578 100644
|
||||
--- a/src/net/milkbowl/vault/Vault.java
|
||||
+++ b/src/net/milkbowl/vault/Vault.java
|
||||
@@ -78,6 +78,7 @@
|
||||
import net.milkbowl.vault.permission.plugins.Permission_KPerms;
|
||||
|
||||
import org.bstats.bukkit.Metrics;
|
||||
+import org.bstats.charts.SimplePie;
|
||||
import org.bukkit.Bukkit;
|
||||
import org.bukkit.OfflinePlayer;
|
||||
import org.bukkit.command.Command;
|
||||
@@ -185,7 +186,7 @@ public void run() {
|
||||
});
|
||||
|
||||
// Load up the Plugin metrics
|
||||
- Metrics metrics = new Metrics(this);
|
||||
+ Metrics metrics = new Metrics(this, 887);
|
||||
findCustomData(metrics);
|
||||
|
||||
log.info(String.format("Enabled Version %s", getDescription().getVersion()));
|
||||
@@ -581,7 +582,7 @@ private void findCustomData(Metrics metrics) {
|
||||
econ = rspEcon.getProvider();
|
||||
}
|
||||
final String econName = econ != null ? econ.getName() : "No Economy";
|
||||
- metrics.addCustomChart(new Metrics.SimplePie("economy", new Callable<String>() {
|
||||
+ metrics.addCustomChart(new SimplePie("economy", new Callable<String>() {
|
||||
@Override
|
||||
public String call() {
|
||||
return econName;
|
||||
@@ -590,7 +591,7 @@ public String call() {
|
||||
|
||||
// Create our Permission Graph and Add our permission Plotters
|
||||
final String permName = Bukkit.getServer().getServicesManager().getRegistration(Permission.class).getProvider().getName();
|
||||
- metrics.addCustomChart(new Metrics.SimplePie("permission", new Callable<String>() {
|
||||
+ metrics.addCustomChart(new SimplePie("permission", new Callable<String>() {
|
||||
@Override
|
||||
public String call() {
|
||||
return permName;
|
||||
@@ -604,7 +605,7 @@ public String call() {
|
||||
chat = rspChat.getProvider();
|
||||
}
|
||||
final String chatName = chat != null ? chat.getName() : "No Chat";
|
||||
- metrics.addCustomChart(new Metrics.SimplePie("chat", new Callable<String>() {
|
||||
+ metrics.addCustomChart(new SimplePie("chat", new Callable<String>() {
|
||||
@Override
|
||||
public String call() {
|
||||
return chatName;
|
42
user/papermc-plugin-vault/APKBUILD
Normal file
42
user/papermc-plugin-vault/APKBUILD
Normal file
|
@ -0,0 +1,42 @@
|
|||
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
||||
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
||||
pkgname=papermc-plugin-vault
|
||||
pkgver=1.7.3
|
||||
pkgrel=0
|
||||
pkgdesc="Vault of common APIs for Bukkit Plugins"
|
||||
options=!check
|
||||
arch='noarch'
|
||||
url="https://github.com/MilkBowl/Vault"
|
||||
license="MIT"
|
||||
depends="papermc>=1.8.8"
|
||||
makedepends="
|
||||
openjdk21-jdk
|
||||
maven
|
||||
"
|
||||
source="
|
||||
vault-$pkgver.tar.gz::https://github.com/MilkBowl/Vault/archive/refs/tags/1.7.3.tar.gz
|
||||
2022cb0_support-newer-jdk-for-building.patch
|
||||
868_update-bstats.patch
|
||||
823_add-option-to-silence-no-update-logs.patch
|
||||
1996cfa_finish-removal-native-support-for-abandonned-economy-plugins.patch
|
||||
"
|
||||
builddir="$srcdir"/Vault-$pkgver
|
||||
|
||||
build() {
|
||||
mvn compile
|
||||
}
|
||||
|
||||
check() {
|
||||
mvn test
|
||||
}
|
||||
|
||||
package() {
|
||||
install -Dm644 "$srcdir"/Vault-$pkgver.jar "$pkgdir/var/lib/papermc/plugins/Vault.jar"
|
||||
}
|
||||
sha512sums="
|
||||
3d154945e63b7824f0a0e0900fe6db7dc77c97f1967c29760d27a3322ca0b95d76965d8574c24b7cc0e86e822f9b5e3f860cb7167796351c9a921ddf5ef3d36b vault-1.7.3.tar.gz
|
||||
8b7197b25acf06e545f10dd7dc5447aab6a73d3455bf89b01a4b466331eefa77c86152a47818348cfb901a0d65cff115b75ae37e0f8bb702c35cf13a3942a484 2022cb0_support-newer-jdk-for-building.patch
|
||||
9124d0feef633f405c3aea6081d4b749df9828d99d0c93d09ba52adb680a781288523d2dfc71be566b8cafd58ac97f152258174ab02294c6e97020a033ee0faa 868_update-bstats.patch
|
||||
b76b385ff62a955430db8d4d60592983e7475e1e63cd6a9e8c0be0a035662ec4472c6f9c8f09125745c198074695b3e04fe6ad96cbafa5faaba72bcf1bfee896 823_add-option-to-silence-no-update-logs.patch
|
||||
ea5e36649e65ca690fd8a075bb5f251a8b449ab780a546007e242ec465c58c8c5ae346efac5f1b52e3287f4f400c658f745d130d1e361ecca3436dcf5cb46fb5 1996cfa_finish-removal-native-support-for-abandonned-economy-plugins.patch
|
||||
"
|
Loading…
Reference in a new issue