testing/py3-whoosh: move from user

This commit is contained in:
Antoine Martin 2023-08-30 13:56:02 -04:00
parent 2b5ea79474
commit 6d7ac191e4
3 changed files with 59 additions and 30 deletions

View file

@ -0,0 +1,46 @@
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=py3-whoosh
_pyname="Whoosh"
pkgver=2.7.4
pkgrel=0
arch="noarch"
pkgdesc="Fast, pure-Python full text indexing, search, and spell checking library"
url="https://pypi.python.org/project/$_pyname"
license="BSD-3-Clause"
makedepends="
py3-setuptools
py3-gpep517
py3-wheel
py3-installer
"
checkdepends="
py3-pytest-runner
"
source="
$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz
test-fix.patch
"
options="!check" # Failing test units
builddir="$srcdir"/$_pyname-$pkgver
subpackages="$pkgname-pyc"
build() {
gpep517 build-wheel \
--wheel-dir dist \
--output-fd 3 3>&1 >&2
}
check() {
PYTHONPATH="$builddir"/src pytest -v
}
package() {
python3 -m installer -d "$pkgdir" \
dist/*.whl
}
sha512sums="
7cdefdcf52b704ffe50c00718c42677e2ddfe879f81ad2d14b580b0e026cc0ebb6b9ddc99d8709eaff4eb9b83f654b042c8792821e1ed90aa85cfa6f82845074 py3-whoosh-2.7.4.tar.gz
191254eb455bc8bf762e0ae05c43cf3dc18ca948a824a8285a0337127d887655998f82a8f5ed807942c0ad14ac78c7c9e3b0742413bc3b19ee949bbd9dbd6e6c test-fix.patch
"

View file

@ -0,0 +1,13 @@
diff --git a/setup.cfg.orig b/setup.cfg
index 1f68c92e6d5..a6a81025aa8 100644
--- a/setup.cfg.orig
+++ b/setup.cfg
@@ -15,7 +15,7 @@ formats = zip,gztar
push = sdist bdist_wheel upload
pushdocs = build_sphinx upload_sphinx
-[pytest]
+[tool:pytest]
addopts = -rs --tb=native
norecursedirs = .hg .tox _build tmp* env* benchmark stress
minversion = 2.0

View file

@ -1,30 +0,0 @@
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=py3-whoosh
_pyname="Whoosh"
pkgver=2.7.4
pkgrel=1
arch="noarch"
pkgdesc="Fast, pure-Python full text indexing, search, and spell checking library"
url="https://pypi.python.org/project/$_pyname"
license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools py3-pytest-runner"
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
build() {
python3 setup.py build
}
check() {
python3 setup.py ptr || warning "Tests failed"
}
package() {
python3 setup.py install --root="$pkgdir"/ --optimize=1 --skip-build
}
sha512sums="
7cdefdcf52b704ffe50c00718c42677e2ddfe879f81ad2d14b580b0e026cc0ebb6b9ddc99d8709eaff4eb9b83f654b042c8792821e1ed90aa85cfa6f82845074 py3-whoosh-2.7.4.tar.gz
"