backports/py3-apsw: new aport
This commit is contained in:
parent
ec7c2275c4
commit
684b9977e3
2 changed files with 54 additions and 0 deletions
46
backports/py3-apsw/APKBUILD
Normal file
46
backports/py3-apsw/APKBUILD
Normal file
|
@ -0,0 +1,46 @@
|
|||
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
|
||||
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
|
||||
pkgname=py3-apsw
|
||||
_pkgname=apsw
|
||||
pkgver=3.45.2.0
|
||||
pkgrel=1
|
||||
pkgdesc="Another Python SQLite Wrapper"
|
||||
url="https://github.com/rogerbinns/apsw"
|
||||
arch="all"
|
||||
license="Zlib"
|
||||
depends="python3"
|
||||
makedepends="
|
||||
python3-dev
|
||||
py3-gpep517
|
||||
py3-setuptools
|
||||
py3-wheel
|
||||
sqlite-dev
|
||||
"
|
||||
subpackages="$pkgname-pyc"
|
||||
source="$pkgname-$pkgver.zip::https://github.com/rogerbinns/apsw/releases/download/$pkgver/apsw-$pkgver.zip
|
||||
detect-sqlite-config.patch
|
||||
"
|
||||
|
||||
builddir="$srcdir/$_pkgname-$pkgver"
|
||||
|
||||
build() {
|
||||
gpep517 build-wheel \
|
||||
--wheel-dir .dist \
|
||||
--output-fd 3 3>&1 >&2
|
||||
}
|
||||
|
||||
check() {
|
||||
python3 -m venv --clear --without-pip --system-site-packages .testenv
|
||||
.testenv/bin/python3 -m installer .dist/*.whl
|
||||
.testenv/bin/python3 setup.py build_test_extension test
|
||||
}
|
||||
|
||||
package() {
|
||||
python3 -m installer -d "$pkgdir" \
|
||||
.dist/*.whl
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
0260f6479d5f1188ad172dfc0dd7e4a03c9d809d2f80c2296e587a19286681bb2ce759b0bd19ec6957e2902f18729b7e79410e4db79dff9918089f57dd510828 py3-apsw-3.45.2.0.zip
|
||||
8f3957bd6fecb5660a7cab367043e4ccdacd87d8963bbe41cc3d525265de28f08aa207099658d785be29c5c90b818c1418f766995cd780d02b8e36252a389758 detect-sqlite-config.patch
|
||||
"
|
8
backports/py3-apsw/detect-sqlite-config.patch
Normal file
8
backports/py3-apsw/detect-sqlite-config.patch
Normal file
|
@ -0,0 +1,8 @@
|
|||
diff --git a/setup.apsw b/setup.apsw
|
||||
index 68dedb9..3ceb10b 100644
|
||||
--- a/setup.apsw
|
||||
+++ b/setup.apsw
|
||||
@@ -1 +1,3 @@
|
||||
# You can put ini format directives here in addition to command line flags
|
||||
+[build_ext]
|
||||
+use_system_sqlite_config = True
|
Loading…
Reference in a new issue