From 5196e9d2ed5064f82b2cccc90ff281e3a8008f41 Mon Sep 17 00:00:00 2001
From: "build@apk-groulx" <build@apk-groulx.praxis>
Date: Sun, 5 Dec 2021 18:33:57 +0000
Subject: [PATCH] [main/dotnet-5.0] Added ApplicationInsights net40 case fix

---
 apk/v3.15/main/dotnet-5.0/APKBUILD              |  6 ++++--
 apk/v3.15/main/dotnet-5.0/README.md             | 12 ++++++++----
 ...plications-insights_fix-net40-location.patch | 17 +++++++++++++++++
 3 files changed, 29 insertions(+), 6 deletions(-)
 create mode 100644 apk/v3.15/main/dotnet-5.0/applications-insights_fix-net40-location.patch

diff --git a/apk/v3.15/main/dotnet-5.0/APKBUILD b/apk/v3.15/main/dotnet-5.0/APKBUILD
index d6ba120..efd3949 100644
--- a/apk/v3.15/main/dotnet-5.0/APKBUILD
+++ b/apk/v3.15/main/dotnet-5.0/APKBUILD
@@ -68,10 +68,11 @@ source="
 	$pkgname-$_gittag.git.zip
 	dotnet.sh
 	https://dot.net/v1/dotnet-install.sh
+	applications-insights_fix-net40-location.patch
+	build_darc-fix-alpine.patch
 	runtime_add-rid-for-alpine-315.patch
 	runtime_link-order.patch
 	runtime_non-portable-distrorid-fix-alpine.patch
-	build_darc-fix-alpine.patch
 	sdk_telemetry-optout.patch
 "
 builddir="$srcdir/$pkgname"
@@ -299,9 +300,10 @@ sha512sums="
 7899483157a32012137e4ee44b03173908f6325085b7ee352ee329a208a0d1e5b434d1f24099e5b346ec9753e23c6a94553e76dc76a1ea6633392758132ed492  dotnet-5.0-v5.0.12.1-runtime.git.zip
 f58bd83b709dcb4b0b67830756069c34258a167b33cb290cbf30f21d69d75402d38e013fd7bbf00640fe19e397f78df6ff787cf8484ee8967d5b8809f033eafb  dotnet.sh
 ecab4809e617e9cd30940b1c1a700e16b37b5974c850a60da7f1a25bf81516850e4533ef39d2d8786381e0e4e325d3b53fbb2377ecaa6c0813bb00fc1c92b784  dotnet-install.sh
+0469d571d0f7634d3794761f04e1cbff9d27d642d134a11a13560574280e5cab6f366eb8820e61a449eca99470fdea8d9f6a7d97b633059b2fe25257ed1579e6  applications-insights_fix-net40-location.patch
+74767c34f15e0eaee3682516e093296621efaeeb6d84e62d826587db9b559fb7c00c42aafbf4fdfd34460d1cf16edad3fd5f720f2b37f8bf52b26d7f73f79d5e  build_darc-fix-alpine.patch
 4899175597a1d4cd14c382469fe17e6d8d4644b784dca02eb2d4f71afa8e898e60269d5b0cdfea6e3ed6dc92feb676c6db21aae3bcb206d859c02cd10cdcaca0  runtime_add-rid-for-alpine-315.patch
 0d6ca9b4c6bb0999102f8a51b408c6f938d7262af552d63ef180fdc9a48bba940d0437d0d06916c3f7be7e70e2717a46a4ebc91c0f85467cbc7776b944eca83e  runtime_link-order.patch
 6dd3ff4db79aa95fa37ba4011da82c74d8ac83a7a92124fc4a97bd78b818b024b569df293b1edae2b16d8161c76b6a00e1c81bd421480e367925af64673b0f84  runtime_non-portable-distrorid-fix-alpine.patch
-74767c34f15e0eaee3682516e093296621efaeeb6d84e62d826587db9b559fb7c00c42aafbf4fdfd34460d1cf16edad3fd5f720f2b37f8bf52b26d7f73f79d5e  build_darc-fix-alpine.patch
 c96700138ea919c169c3a394f1bf9548c7f86b1ba42b193d6e7bb0a1e2bd6f7f202befbc61246a8720181cd40e1f7fa36a6c208eb19b03a23e21994136fb2507  sdk_telemetry-optout.patch
 "
diff --git a/apk/v3.15/main/dotnet-5.0/README.md b/apk/v3.15/main/dotnet-5.0/README.md
index 22e9ad5..776f3ff 100644
--- a/apk/v3.15/main/dotnet-5.0/README.md
+++ b/apk/v3.15/main/dotnet-5.0/README.md
@@ -21,6 +21,14 @@ a way to adjust this, but for now this will do.
 
 # Patch notes
 
+## applications-insights_fix-net40-location.patch
+   Because paths on Linux are case sensitive. Applications insights looks
+   for <dotnet/applications-insights>/src/Core/Managed/net40 in net40 
+   while the repo has a Net40. Patch moves whatever is in Net40 to net40
+## build_darc-fix-alpine.patch
+   Darc has a segmentation fault on Alpine due to not chosing the correct
+   binary architecture. This patch deletes all the wrong ones so that it
+   is forced to chose the correct one. See dotnet/source-build issue #1868.
 ## runtime_add-rid-for-alpine-315.patch/_
    As of version 5.0.12, runtime does not have the RIDs for Alpine Linux 3.15.
    This patch adds them. See dotnet/core issue #6985 
@@ -30,10 +38,6 @@ a way to adjust this, but for now this will do.
    Runtime adds the extra subversion in its calculation of Alpine's DistroRID
    when a non-portable build, but does so inconsistently. This creates an error
    when it generates its nuget package.
-## build_darc-fix-alpine.patch
-   Darc has a segmentation fault on Alpine due to not chosing the correct
-   binary architecture. This patch deletes all the wrong ones so that it
-   is forced to chose the correct one. See dotnet/source-build issue #1868.
 ## sdk_telemetry-optout.patch
    Optouts of telemetry gathering
 
diff --git a/apk/v3.15/main/dotnet-5.0/applications-insights_fix-net40-location.patch b/apk/v3.15/main/dotnet-5.0/applications-insights_fix-net40-location.patch
new file mode 100644
index 0000000..753b310
--- /dev/null
+++ b/apk/v3.15/main/dotnet-5.0/applications-insights_fix-net40-location.patch
@@ -0,0 +1,17 @@
+From 387efb0ac01e40cd85cf9f5ce770be6437265ca4 Mon Sep 17 00:00:00 2001
+From: "build@apk-groulx" <build@apk-groulx.praxis>
+Date: Fri, 4 Jun 2021 13:32:53 +0000
+Subject: [PATCH] FIxed Net40 location
+
+---
+ src/Core/Managed/{Net40 => net40}/CorrelationHelper.cs | 0
+ 1 file changed, 0 insertions(+), 0 deletions(-)
+ rename src/Core/Managed/{Net40 => net40}/CorrelationHelper.cs (100%)
+
+diff --git a/src/Core/Managed/Net40/CorrelationHelper.cs b/src/Core/Managed/net40/CorrelationHelper.cs
+similarity index 100%
+rename from src/Core/Managed/Net40/CorrelationHelper.cs
+rename to src/Core/Managed/net40/CorrelationHelper.cs
+-- 
+2.30.2
+