diff --git a/user/protobuf/APKBUILD b/user/protobuf/APKBUILD
deleted file mode 100644
index ec56f54..0000000
--- a/user/protobuf/APKBUILD
+++ /dev/null
@@ -1,168 +0,0 @@
-# Contributor: Sheila Aman <sheila@vulpine.house>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=protobuf
-_gemname=google-protobuf
-pkgver=23.4
-_rubyver=3.23.4
-pkgrel=2
-pkgdesc="Library for extensible, efficient structure packing"
-url="https://github.com/protocolbuffers/protobuf"
-arch="all"
-license="BSD-3-Clause"
-depends="
-	protoc=$pkgver-r$pkgrel
-	libprotoc=$pkgver-r$pkgrel
-	libprotobuf=$pkgver-r$pkgrel
-	libprotobuf-lite=$pkgver-r$pkgrel
-	"
-depends_dev="
-	protoc=$pkgver-r$pkgrel
-	zlib-dev
-	"
-makedepends="
-	$depends_dev
-	abseil-cpp-dev
-	cmake
-	ruby3.2
-	ruby3.2-dev
-	ruby3.2-rake
-	samurai
-	"
-checkdepends="gtest-dev"
-subpackages="
-	ruby3.2-$_gemname:_ruby
-	$pkgname-dev
-	$pkgname-vim::noarch
-	protoc
-	libprotoc
-	libprotobuf
-	libprotobuf-lite
-	"
-	# exclude.patch
-source="$pkgname-$pkgver.tar.gz::https://github.com/protocolbuffers/protobuf/archive/refs/tags/v$pkgver.tar.gz
-	exclude.patch
-	protoc-cmake.patch
-	ruby-fix-cflags.patch
-	skip-failing-tests.patch
-	soversion.patch
-	trim-rakefile.patch
-	"
-
-# fails some
-case "$CARCH" in
-armhf) options="$options !check" ;;
-esac
-
-build() {
-	export CFLAGS="$CFLAGS -DNDEBUG -O2 -flto=auto"
-	export CXXFLAGS="$CXXFLAGS -DNDEBUG -O2 -flto=auto -Wno-deprecated-declarations"
-
-	cmake -B build -G Ninja \
-		-DCMAKE_BUILD_TYPE=None \
-		-DCMAKE_INSTALL_PREFIX=/usr \
-		-DBUILD_SHARED_LIBS=ON \
-		-Dprotobuf_BUILD_TESTS="$(want_check && echo ON || echo OFF)" \
-		-Dprotobuf_BUILD_LIBPROTOC=ON \
-		-Dprotobuf_ABSL_PROVIDER="package" \
-		-Dprotobuf_ALLOW_CCACHE=ON \
-		-Dprotobuf_USE_EXTERNAL_GTEST=ON
-	cmake --build build
-
-	cd "$builddir"/ruby
-
-	export PATH="$PATH:$builddir/build"
-
-	# Generate proto files for built-in protocols.
-	rake genproto
-
-	gem build $_gemname.gemspec
-	gem install --local \
-		--install-dir dist \
-		--ignore-dependencies \
-		--no-document \
-		--verbose \
-		$_gemname
-}
-
-# TODO: Run tests for ruby gem.
-check() {
-	ctest --test-dir build --output-on-failure
-}
-
-package() {
-	DESTDIR="$pkgdir" cmake --install build
-
-	sed -i \
-		-e "/Requires:/s|;| |g" \
-		-e "/Requires:/s|::|_|g" \
-		"$pkgdir"/usr/lib/pkgconfig/protobuf.pc
-
-	install -Dm644 editors/proto.vim \
-		"$pkgdir"/usr/share/vim/vimfiles/syntax/proto.vim
-
-	local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
-	cd ruby/dist
-
-	mkdir -p "$gemdir"
-	cp -r extensions gems specifications "$gemdir"/
-
-	# Remove duplicated .so libs (should be only in extensions directory).
-	find "$gemdir"/gems/ -name "*.so" -delete
-
-	# Remove unnecessary files.
-	cd "$gemdir"/gems/$_gemname-$_rubyver
-	rm -r ext/
-}
-
-_ruby() {
-	depends=""
-	pkgdesc="Ruby bindings to Google's data interchange format"
-
-	amove usr/lib/ruby/gems
-}
-
-vim() {
-	pkgdesc="Vim syntax for $pkgname"
-	depends=""
-	install_if="$pkgname=$pkgver-r$pkgrel vim"
-
-	amove usr/share/vim/vimfiles/syntax/proto.vim
-}
-
-libprotoc() {
-	depends=""
-	pkgdesc="Runtime library for Protocol Buffer compiler"
-
-	amove usr/lib/libprotoc.so.*
-}
-
-protoc() {
-	depends=""
-	pkgdesc="Protocol buffer compiler binary and library"
-
-	amove usr/bin/protoc*
-}
-
-libprotobuf() {
-	depends=""
-	pkgdesc="Runtime library for C++ users of protocol buffers"
-
-	amove usr/lib/libprotobuf.so.*
-}
-
-lite() {
-	depends=""
-	pkgdesc="Runtime library for C++ users with 'lite runtime' setting of protocol buffers"
-
-	amove usr/lib/libprotobuf-lite.so.*
-}
-
-sha512sums="
-b93a4e0339ecbe085796de5b6c61feae35229d40db9019c043090bcaa483a1cce78a99487c5638482c68832fcede5579a0e5ec731221a88359b80db9bb6dc566  protobuf-23.4.tar.gz
-0d46d105a0670ab5cfcb04ed534927a71613234a88efede0b20d426e1caaa708e6ff275a09c5dab7786fe26e69e0882f022b893302e4869006b4ac55fc6172e5  exclude.patch
-16b8ee0e50dbb2144ddb83654a63e410b4218e667b6b8b77c7b6f9797508f63c3e8be0f9711841bb6ebbed0883cda2394b219a62b468240f65f4dac418b5a56e  protoc-cmake.patch
-0cb202a6151ae3746c09e85f2e4ce9abb0d810d4a3c84cb647fde407cf8d13894d3c9b340e06d7a3a85669da1899db265d26d8309d59249f841a40a66e045c83  ruby-fix-cflags.patch
-b5070f8e150920c316130ba40f46c66eefddc634844f5d6b8ee11f6824a3707b3e74f68aa0612c16305bf096050214c6120e693225e07e0cea80e68a7830f863  skip-failing-tests.patch
-850dc1d6fd3ea01f1689fd700ac35e7da0882092ab34c616702e01bdf4b5327b8ab27381ecf291431a94f54c89d31707a4a171929937e880543974cb64f9e685  soversion.patch
-13514a456a50d7243baa23fe43586fc4544cda87b9e2a5afe9d2fac8afca8e8853f9b42232c3fff4c5cf2df443af32f944f451daa1d604d80fd03ee4e7abed3e  trim-rakefile.patch
-"
diff --git a/user/protobuf/exclude.patch b/user/protobuf/exclude.patch
deleted file mode 100644
index 9c63c0a..0000000
--- a/user/protobuf/exclude.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-don't install the utf8_range lib into disk.
-also remove it from .pc/cmake, it's statically linked into protobuf and never needed on disk after
---
-diff --git a/cmake/install.cmake b/cmake/install.cmake
-index e7eb210..73e1897 100644
---- a/cmake/install.cmake
-+++ b/cmake/install.cmake
-@@ -4,7 +4,6 @@ foreach(_target IN LISTS protobuf_ABSL_USED_TARGETS)
-   string(REPLACE :: _ _modified_target ${_target})
-   list(APPEND _pc_targets ${_modified_target})
- endforeach()
--list(APPEND _pc_targets "utf8_range")
- 
- set(_protobuf_PC_REQUIRES "")
- set(_sep "")
-diff --git a/cmake/protobuf-config.cmake.in b/cmake/protobuf-config.cmake.in
-index 44805c7..1a8d243 100644
---- a/cmake/protobuf-config.cmake.in
-+++ b/cmake/protobuf-config.cmake.in
-@@ -4,7 +4,6 @@ include("${CMAKE_CURRENT_LIST_DIR}/protobuf-options.cmake")
- # Depend packages
- @_protobuf_FIND_ZLIB@
- @_protobuf_FIND_ABSL@
--@_protobuf_FIND_UTF8_RANGE@
- 
- # Imported targets
- include("${CMAKE_CURRENT_LIST_DIR}/protobuf-targets.cmake")
-diff --git a/cmake/utf8_range.cmake b/cmake/utf8_range.cmake
-index f411a8c..770f94c 100644
---- a/cmake/utf8_range.cmake
-+++ b/cmake/utf8_range.cmake
-@@ -8,7 +8,7 @@ if (NOT TARGET utf8_range)
-   endif()
- 
-   set(utf8_range_ENABLE_INSTALL ${protobuf_INSTALL} CACHE BOOL "Set install")
--  add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/third_party/utf8_range third_party/utf8_range)
-+  add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/third_party/utf8_range third_party/utf8_range EXCLUDE_FROM_ALL)
-   include_directories(${CMAKE_CURRENT_SOURCE_DIR}/third_party/utf8_range)
- endif ()
- 
diff --git a/user/protobuf/protoc-cmake.patch b/user/protobuf/protoc-cmake.patch
deleted file mode 100644
index 4c1ae7a..0000000
--- a/user/protobuf/protoc-cmake.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Patch-Source: https://github.com/protocolbuffers/protobuf/pull/13206
---
-From 2e62ef1eaa2e712afc5f87aa2c55d478fe96230d Mon Sep 17 00:00:00 2001
-From: Antonio Rojas <arojas@archlinux.org>
-Date: Wed, 5 Jul 2023 13:03:11 +0200
-Subject: [PATCH] Handle BUILD_TYPE=None in protobuf-module.cmake
-
-Fixes Protobuf_PROTOC_EXECUTABLE being undefined in that case.
----
- cmake/protobuf-module.cmake.in | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/cmake/protobuf-module.cmake.in b/cmake/protobuf-module.cmake.in
-index 0bb05e38fad..e5b2b2e4b3a 100644
---- a/cmake/protobuf-module.cmake.in
-+++ b/cmake/protobuf-module.cmake.in
-@@ -153,6 +153,10 @@ if(NOT Protobuf_PROTOC_EXECUTABLE AND TARGET protobuf::protoc)
-     get_target_property(Protobuf_PROTOC_EXECUTABLE protobuf::protoc
-       IMPORTED_LOCATION_NOCONFIG)
-   endif()
-+  if(NOT EXISTS "${Protobuf_PROTOC_EXECUTABLE}")
-+    get_target_property(Protobuf_PROTOC_EXECUTABLE protobuf::protoc
-+      IMPORTED_LOCATION_NONE)
-+  endif()
- endif()
- 
- # Version info variable
diff --git a/user/protobuf/ruby-fix-cflags.patch b/user/protobuf/ruby-fix-cflags.patch
deleted file mode 100644
index 24b1d57..0000000
--- a/user/protobuf/ruby-fix-cflags.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Using builder flags
-
-diff --git a/ruby/ext/google/protobuf_c/extconf.rb b/ruby/ext/google/protobuf_c/extconf.rb
-index b7c439b..0bbc15c 100755
---- a/ruby/ext/google/protobuf_c/extconf.rb
-+++ b/ruby/ext/google/protobuf_c/extconf.rb
-@@ -7,9 +7,9 @@ ext_name = "google/protobuf_c"
- dir_config(ext_name)
- 
- if RUBY_PLATFORM =~ /darwin/ || RUBY_PLATFORM =~ /linux/ || RUBY_PLATFORM =~ /freebsd/
--  $CFLAGS += " -std=gnu99 -O3 -DNDEBUG -fvisibility=hidden -Wall -Wsign-compare -Wno-declaration-after-statement"
-+  $CFLAGS += " -std=gnu99 -DNDEBUG -fvisibility=hidden -Wall -Wsign-compare -Wno-declaration-after-statement"
- else
--  $CFLAGS += " -std=gnu99 -O3 -DNDEBUG"
-+  $CFLAGS += " -std=gnu99 -DNDEBUG"
- end
- 
- if RUBY_PLATFORM =~ /linux/
diff --git a/user/protobuf/skip-failing-tests.patch b/user/protobuf/skip-failing-tests.patch
deleted file mode 100644
index be0c71b..0000000
--- a/user/protobuf/skip-failing-tests.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-diff --git a/src/google/protobuf/any_test.cc b/src/google/protobuf/any_test.cc
-index 8b544d9..0f27dbe 100644
---- a/src/google/protobuf/any_test.cc
-+++ b/src/google/protobuf/any_test.cc
-@@ -62,13 +62,6 @@ TEST(AnyTest, TestPackAndUnpack) {
-   EXPECT_EQ(12345, submessage.int32_value());
- }
- 
--TEST(AnyTest, TestPackFromSerializationExceedsSizeLimit) {
--  protobuf_unittest::TestAny submessage;
--  submessage.mutable_text()->resize(INT_MAX, 'a');
--  protobuf_unittest::TestAny message;
--  EXPECT_FALSE(message.mutable_any_value()->PackFrom(submessage));
--}
--
- TEST(AnyTest, TestUnpackWithTypeMismatch) {
-   protobuf_unittest::TestAny payload;
-   payload.set_int32_value(13);
-diff --git a/src/google/protobuf/arena_unittest.cc b/src/google/protobuf/arena_unittest.cc
-index 4832cff..aa45a25 100644
---- a/src/google/protobuf/arena_unittest.cc
-+++ b/src/google/protobuf/arena_unittest.cc
-@@ -1392,11 +1392,11 @@ TEST(ArenaTest, SpaceAllocated_and_Used) {
-   options.initial_block_size = arena_block.size();
-   Arena arena_2(options);
-   EXPECT_EQ(1024, arena_2.SpaceAllocated());
--  EXPECT_EQ(0, arena_2.SpaceUsed());
-+//  EXPECT_EQ(0, arena_2.SpaceUsed());
-   EXPECT_EQ(1024, arena_2.Reset());
-   Arena::CreateArray<char>(&arena_2, 55);
-   EXPECT_EQ(1024, arena_2.SpaceAllocated());
--  EXPECT_EQ(Align8(55), arena_2.SpaceUsed());
-+//  EXPECT_EQ(Align8(55), arena_2.SpaceUsed());
-   EXPECT_EQ(1024, arena_2.Reset());
- }
- 
-@@ -1460,11 +1460,11 @@ TEST(ArenaTest, BlockSizeSmallerThanAllocation) {
- 
-     *Arena::Create<int64_t>(&arena) = 42;
-     EXPECT_GE(arena.SpaceAllocated(), 8);
--    EXPECT_EQ(8, arena.SpaceUsed());
-+//    EXPECT_EQ(8, arena.SpaceUsed());
- 
-     *Arena::Create<int64_t>(&arena) = 42;
-     EXPECT_GE(arena.SpaceAllocated(), 16);
--    EXPECT_EQ(16, arena.SpaceUsed());
-+//    EXPECT_EQ(16, arena.SpaceUsed());
-   }
- }
- 
-diff --git a/src/google/protobuf/extension_set_unittest.cc b/src/google/protobuf/extension_set_unittest.cc
-index ccd1c9b..f420da3 100644
---- a/src/google/protobuf/extension_set_unittest.cc
-+++ b/src/google/protobuf/extension_set_unittest.cc
-@@ -871,17 +871,17 @@ TEST(ExtensionSetTest, SpaceUsedExcludingSelf) {
-   } while (0)
- 
-   TEST_REPEATED_EXTENSIONS_SPACE_USED(int32, int32_t, 101);
--  TEST_REPEATED_EXTENSIONS_SPACE_USED(int64, int64_t, 102);
-+  //TEST_REPEATED_EXTENSIONS_SPACE_USED(int64, int64_t, 102);
-   TEST_REPEATED_EXTENSIONS_SPACE_USED(uint32, uint32_t, 103);
--  TEST_REPEATED_EXTENSIONS_SPACE_USED(uint64, uint64_t, 104);
-+  //TEST_REPEATED_EXTENSIONS_SPACE_USED(uint64, uint64_t, 104);
-   TEST_REPEATED_EXTENSIONS_SPACE_USED(sint32, int32_t, 105);
--  TEST_REPEATED_EXTENSIONS_SPACE_USED(sint64, int64_t, 106);
-+  //TEST_REPEATED_EXTENSIONS_SPACE_USED(sint64, int64_t, 106);
-   TEST_REPEATED_EXTENSIONS_SPACE_USED(fixed32, uint32_t, 107);
--  TEST_REPEATED_EXTENSIONS_SPACE_USED(fixed64, uint64_t, 108);
-+  //TEST_REPEATED_EXTENSIONS_SPACE_USED(fixed64, uint64_t, 108);
-   TEST_REPEATED_EXTENSIONS_SPACE_USED(sfixed32, int32_t, 109);
--  TEST_REPEATED_EXTENSIONS_SPACE_USED(sfixed64, int64_t, 110);
-+  //TEST_REPEATED_EXTENSIONS_SPACE_USED(sfixed64, int64_t, 110);
-   TEST_REPEATED_EXTENSIONS_SPACE_USED(float, float, 111);
--  TEST_REPEATED_EXTENSIONS_SPACE_USED(double, double, 112);
-+  //TEST_REPEATED_EXTENSIONS_SPACE_USED(double, double, 112);
-   TEST_REPEATED_EXTENSIONS_SPACE_USED(bool, bool, true);
-   TEST_REPEATED_EXTENSIONS_SPACE_USED(nested_enum, int,
-                                       unittest::TestAllTypes::FOO);
-diff --git a/src/google/protobuf/wire_format_unittest.inc b/src/google/protobuf/wire_format_unittest.inc
-index 4c7d047..7906cfa 100644
---- a/src/google/protobuf/wire_format_unittest.inc
-+++ b/src/google/protobuf/wire_format_unittest.inc
-@@ -1537,6 +1537,7 @@ TEST_F(Utf8ValidationTest, ParseRepeatedString) {
- 
- // Test the old VerifyUTF8String() function, which may still be called by old
- // generated code.
-+#if 0
- TEST_F(Utf8ValidationTest, OldVerifyUTF8String) {
-   std::string data(kInvalidUTF8String);
- 
-@@ -1555,7 +1556,7 @@ TEST_F(Utf8ValidationTest, OldVerifyUTF8String) {
-                                  WireFormat::SERIALIZE);
-   }
- }
--
-+#endif
- 
- TEST(RepeatedVarint, Int32) {
-   RepeatedField<int32_t> v;
diff --git a/user/protobuf/soversion.patch b/user/protobuf/soversion.patch
deleted file mode 100644
index 25d6959..0000000
--- a/user/protobuf/soversion.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Patch-Source: https://gitlab.archlinux.org/archlinux/packaging/packages/protobuf/-/blob/e93df92fead2d46cc2825a866af3f402d498439c/soversion.patch
-use an soversion that actually makes sense and not just the full pkgver
---
-diff --git a/cmake/libprotobuf-lite.cmake b/cmake/libprotobuf-lite.cmake
-index 9b1de677b4f..276c99c489e 100644
---- a/cmake/libprotobuf-lite.cmake
-+++ b/cmake/libprotobuf-lite.cmake
-@@ -30,6 +30,7 @@ if(protobuf_BUILD_SHARED_LIBS)
- endif()
- set_target_properties(libprotobuf-lite PROPERTIES
-     VERSION ${protobuf_VERSION}
-+    SOVERSION ${protobuf_VERSION_MINOR}
-     OUTPUT_NAME ${LIB_PREFIX}protobuf-lite
-     DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
- add_library(protobuf::libprotobuf-lite ALIAS libprotobuf-lite)
-diff --git a/cmake/libprotobuf.cmake b/cmake/libprotobuf.cmake
-index aa3efc9a68a..0f34d20b97d 100644
---- a/cmake/libprotobuf.cmake
-+++ b/cmake/libprotobuf.cmake
-@@ -33,6 +33,7 @@ if(protobuf_BUILD_SHARED_LIBS)
- endif()
- set_target_properties(libprotobuf PROPERTIES
-     VERSION ${protobuf_VERSION}
-+    SOVERSION ${protobuf_VERSION_MINOR}
-     OUTPUT_NAME ${LIB_PREFIX}protobuf
-     DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
- add_library(protobuf::libprotobuf ALIAS libprotobuf)
-diff --git a/cmake/libprotoc.cmake b/cmake/libprotoc.cmake
-index 72b4a1abb92..91e8bbeb04e 100644
---- a/cmake/libprotoc.cmake
-+++ b/cmake/libprotoc.cmake
-@@ -24,6 +24,7 @@ endif()
- set_target_properties(libprotoc PROPERTIES
-     COMPILE_DEFINITIONS LIBPROTOC_EXPORTS
-     VERSION ${protobuf_VERSION}
-+    SOVERSION ${protobuf_VERSION_MINOR}
-     OUTPUT_NAME ${LIB_PREFIX}protoc
-     DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
- add_library(protobuf::libprotoc ALIAS libprotoc)
diff --git a/user/protobuf/trim-rakefile.patch b/user/protobuf/trim-rakefile.patch
deleted file mode 100644
index d8a3b87..0000000
--- a/user/protobuf/trim-rakefile.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-diff --git a/ruby/Rakefile b/ruby/Rakefile
-index c05e115..20144b7 100644
---- a/ruby/Rakefile
-+++ b/ruby/Rakefile
-@@ -1,6 +1,4 @@
- require "rubygems"
--require "rubygems/package_task"
--require "rake/extensiontask" unless RUBY_PLATFORM == "java"
- require "rake/testtask"
- 
- spec = Gem::Specification.load("google-protobuf.gemspec")
-@@ -95,57 +93,6 @@ else
-     FileUtils.cp(utf8_root+"/range2-neon.c", "ext/google/protobuf_c")
-     FileUtils.cp(utf8_root+"/range2-sse.c", "ext/google/protobuf_c")
-   end
--
--  Rake::ExtensionTask.new("protobuf_c", spec) do |ext|
--    unless RUBY_PLATFORM =~ /darwin/
--      # TODO: also set "no_native to true" for mac if possible. As is,
--      # "no_native" can only be set if the RUBY_PLATFORM doing
--      # cross-compilation is contained in the "ext.cross_platform" array.
--      ext.no_native = true
--    end
--    ext.ext_dir = "ext/google/protobuf_c"
--    ext.lib_dir = "lib/google"
--    ext.cross_compile = true
--    ext.cross_platform = [
--      'x86-mingw32', 'x64-mingw32', 'x64-mingw-ucrt',
--      'x86_64-linux', 'x86-linux',
--      'x86_64-darwin', 'arm64-darwin',
--    ]
--  end
--
--  task 'gem:java' do
--    sh "rm Gemfile.lock"
--    require 'rake_compiler_dock'
--    # Specify the repo root as the working and mount directory to provide access
--    # to the java directory
--    repo_root = File.realdirpath File.join(Dir.pwd, '..')
--    RakeCompilerDock.sh <<-"EOT", platform: 'jruby', rubyvm: :jruby, mountdir: repo_root, workdir: repo_root
--      sudo apt-get install maven -y && \
--      cd java && mvn install -Dmaven.test.skip=true && cd ../ruby && \
--      bundle && \
--      IN_DOCKER=true rake compile gem
--    EOT
--  end
--
--  task 'gem:windows' do
--    sh "rm Gemfile.lock"
--    require 'rake_compiler_dock'
--    ['x86-mingw32', 'x64-mingw32', 'x64-mingw-ucrt', 'x86_64-linux', 'x86-linux'].each do |plat|
--      RakeCompilerDock.sh <<-"EOT", platform: plat
--        bundle && \
--        IN_DOCKER=true rake native:#{plat} pkg/#{spec.full_name}-#{plat}.gem RUBY_CC_VERSION=3.1.0:3.0.0:2.7.0:2.6.0
--      EOT
--    end
--  end
--
--  if RUBY_PLATFORM =~ /darwin/
--    task 'gem:native' do
--      system "rake genproto"
--      system "rake cross native gem RUBY_CC_VERSION=3.1.0:3.0.0:2.7.0:2.6.0"
--    end
--  else
--    task 'gem:native' => [:genproto, 'gem:windows', 'gem:java']
--  end
- end
- 
- task :genproto => genproto_output
-@@ -154,9 +101,6 @@ task :clean do
-   sh "rm -f #{genproto_output.join(' ')}"
- end
- 
--Gem::PackageTask.new(spec) do |pkg|
--end
--
- # Skip build/genproto in Bazel builds, where we expect this to
- # be done already.
- Rake::TestTask.new(:test => ENV['BAZEL'] == 'true' ? [] : [:build, :genproto]) do |t|