backports/py3-a2wsgi: drop for in community
This commit is contained in:
parent
a9b84f6a7d
commit
33f1b837de
2 changed files with 0 additions and 52 deletions
|
@ -1,40 +0,0 @@
|
||||||
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
|
|
||||||
pkgname=py3-a2wsgi
|
|
||||||
pkgver=1.8.0
|
|
||||||
pkgrel=0
|
|
||||||
pkgdesc="Convert WSGI app to ASGI app or ASGI app to WSGI app"
|
|
||||||
url="https://github.com/abersheeran/a2wsgi"
|
|
||||||
arch="noarch"
|
|
||||||
license="Apache-2.0"
|
|
||||||
depends="python3"
|
|
||||||
makedepends="py3-gpep517 py3-pdm-backend py3-wheel"
|
|
||||||
checkdepends="py3-pytest py3-httpx py3-pytest-asyncio"
|
|
||||||
subpackages="$pkgname-pyc"
|
|
||||||
source="https://github.com/abersheeran/a2wsgi/archive/refs/tags/v$pkgver/a2wsgi-$pkgver.tar.gz"
|
|
||||||
builddir="$srcdir/a2wsgi-$pkgver"
|
|
||||||
|
|
||||||
case "$CARCH" in
|
|
||||||
# test suite blocked by py3-httpx
|
|
||||||
armhf|ppc64le) options="!check" ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
build() {
|
|
||||||
gpep517 build-wheel \
|
|
||||||
--wheel-dir .dist \
|
|
||||||
--output-fd 3 3>&1 >&2
|
|
||||||
}
|
|
||||||
|
|
||||||
check() {
|
|
||||||
python3 -m venv --clear --without-pip --system-site-packages .testenv
|
|
||||||
.testenv/bin/python3 -m installer .dist/*.whl
|
|
||||||
.testenv/bin/python3 -m pytest
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
python3 -m installer -d "$pkgdir" \
|
|
||||||
.dist/*.whl
|
|
||||||
}
|
|
||||||
|
|
||||||
sha512sums="
|
|
||||||
0c3a45ea279e2c104a52a7b70780de7a055312e857b712b534020a2c9f43b62b5d60639b5ce721c5e3717f0315c58496134813772613135b22111905df10d5ad a2wsgi-1.8.0.tar.gz
|
|
||||||
"
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff --git a/pyproject.toml b/pyproject.toml
|
|
||||||
index 2e67514..c7f3b40 100644
|
|
||||||
--- a/pyproject.toml
|
|
||||||
+++ b/pyproject.toml
|
|
||||||
@@ -35,5 +35,5 @@ benchmark = [
|
|
||||||
includes = ["a2wsgi"]
|
|
||||||
|
|
||||||
[build-system]
|
|
||||||
-build-backend = "pdm.pep517.api"
|
|
||||||
-requires = ["pdm-pep517>=1.0.0"]
|
|
||||||
+build-backend = "pdm.backend"
|
|
||||||
+requires = ["pdm-backend>=1.0.0"]
|
|
Loading…
Add table
Reference in a new issue