backports/signal-desktop: upgrade to 6.46.0
This commit is contained in:
parent
6bfd1707ab
commit
150a546396
6 changed files with 9 additions and 198 deletions
|
@ -1,7 +1,7 @@
|
|||
# Contributor: lauren n. liberda <lauren@selfisekai.rocks>
|
||||
# Maintainer: lauren n. liberda <lauren@selfisekai.rocks>
|
||||
pkgname=signal-desktop
|
||||
pkgver=6.40.0
|
||||
pkgver=6.46.0
|
||||
pkgrel=0
|
||||
pkgdesc="A messaging app for simple private communication with friends"
|
||||
url="https://github.com/signalapp/Signal-Desktop/"
|
||||
|
@ -61,17 +61,17 @@ makedepends="
|
|||
options="net !check"
|
||||
|
||||
# follow signal-desktop package.json -> @signalapp/libsignal-client
|
||||
_libsignalver=0.32.1
|
||||
_libsignalver=0.39.1
|
||||
|
||||
# follow signal-desktop package.json -> @signalapp/ringrtc
|
||||
_ringrtcver=2.34.3
|
||||
_ringrtcver=2.36.0
|
||||
|
||||
# follow ringrtc (on version above) -> config/version.properties -> webrtc.version
|
||||
# downloading tarball generated with abuild snapshot (with gclient dependencies fetched)
|
||||
_webrtcver=5845j
|
||||
_webrtcver=5993d
|
||||
|
||||
# follow @signalapp/better-sqlite3 (on version in package.json) -> deps/download.js -> TOKENIZER_VERSION
|
||||
# last bsqlite version: 8.5.2
|
||||
# last bsqlite version: 8.6.0
|
||||
_stokenizerver=0.2.1
|
||||
|
||||
source="
|
||||
|
@ -464,10 +464,10 @@ package() {
|
|||
}
|
||||
|
||||
sha512sums="
|
||||
6666029a4b7d163eb5d5833a73c699d11ddd56a644a66da3363b5874ff50469add0c1415b41e568882c9f33cec72024f6c2a50774f9b182d0634d24fb831119a Signal-Desktop-6.40.0.tar.gz
|
||||
855f053a1329d12e20f254f607db0c0db9f6e1a3eb10061996da75805bf462a5dee0f4f841ec679980c77da87d600f92a21cd643c36d44e017cb3cbf57003b09 libsignal-0.32.1.tar.gz
|
||||
83df430ead75eb965513b9dec9e722d10fc4c74dc6dba8ee809bd2b77657c9d545b8d72c00a99273183c3fbcaf94ee9894c5a2d57f45ffeb3419a9957fe74426 ringrtc-2.34.3.tar.gz
|
||||
a1e78d6c8fed69dbc9ece48dc2e5f0e38ab74d3483e02059c90abe9f0be6d915d0a135a0498c05fd9ef87f444b34efb0d67d7dc577f086cba4a6012981d9d9bd webrtc-5845j.tar.zst
|
||||
111aadf2f2b4972a01a08b14351b9cd6e5fa2691fa687a2671a10c493ea3b8089e30d2d6fafb058cbc547a9fb9e0a220a19d39328e17ba9ff1a26c7b5d86b3ce Signal-Desktop-6.46.0.tar.gz
|
||||
c55ca3822836a2cce69d8b9b4f2a5e9a7883ca12824e3da56bb2674fa925559cc7e3fb8676526108d413e34e8e6590e5d4497f38b7a355f633c92f008ae98c7a libsignal-0.39.1.tar.gz
|
||||
f0aae6c33003969064a654948f666223f4380a94e7f96b3d329095a5f0e28189705281b57adc9bcfcab550619bc325faa136f728e6e3a58c32f2118d4759f302 ringrtc-2.36.0.tar.gz
|
||||
20d4264f7d5b8e258eb3f5c453ca95ad6bb44dd5115c3e9d2b1044354889f364a2ddced15c4b15f17ca51afc9d4603bd5e9e3b20bc37f3c0fb79e4edf15fe078 webrtc-5993d.tar.zst
|
||||
84a1f2fc29262a12842e94698d124a85b823128e72a493b0be8ea92fbb72c5c268499f4a6827cdedaae06ec73cce4039a39fe5c5d536cbef330e59ba0183da28 stokenizer-0.2.1.tar.gz
|
||||
be5b4e823543b79175a12314f10c6326d9f0d59f470136962daed4665887006acc05b48b40dc1b67747396d8f6f7d23be298c1e110ccdd35ff9b09d5e6b80bab bettersqlite-use-system-sqlcipher.patch
|
||||
90d47914e30f095515c47c9ef7c763a7a2583a281228d6ea7e2a3444be670b3ae506c82b4fcea8a228f88f688a43c23c8dcef52b65805d2105287234550718a5 libsignal-auditable.patch
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
diff --git a/rust/attest/src/dcap/sgx_report_body.rs b/rust/attest/src/dcap/sgx_report_body.rs
|
||||
index 056bef2b..6d3f0d5d 100644
|
||||
--- a/rust/attest/src/dcap/sgx_report_body.rs
|
||||
+++ b/rust/attest/src/dcap/sgx_report_body.rs
|
||||
@@ -20,7 +20,7 @@ const SGX_HASH_SIZE: usize = 32;
|
||||
|
||||
pub type MREnclave = [u8; SGX_HASH_SIZE];
|
||||
|
||||
-#[derive(Debug)]
|
||||
+#[derive(Copy, Clone, Debug)]
|
||||
#[repr(C, packed)]
|
||||
// sgx_report_body_t
|
||||
pub(crate) struct SgxReportBody {
|
||||
diff --git a/rust/attest/src/endian.rs b/rust/attest/src/endian.rs
|
||||
index ae9351eb..2e08c711 100644
|
||||
--- a/rust/attest/src/endian.rs
|
||||
+++ b/rust/attest/src/endian.rs
|
||||
@@ -7,7 +7,7 @@ use std::convert::{TryFrom, TryInto};
|
||||
|
||||
use hex::FromHex;
|
||||
|
||||
-#[derive(Debug)]
|
||||
+#[derive(Copy, Clone, Debug)]
|
||||
#[repr(C, packed)]
|
||||
pub(crate) struct UInt16LE {
|
||||
bytes: [u8; 2],
|
||||
@@ -27,7 +27,7 @@ impl From<u16> for UInt16LE {
|
||||
}
|
||||
}
|
||||
|
||||
-#[derive(Debug)]
|
||||
+#[derive(Copy, Clone, Debug)]
|
||||
#[repr(C, packed)]
|
||||
pub(crate) struct UInt32LE {
|
||||
bytes: [u8; 4],
|
||||
@@ -66,7 +66,7 @@ impl FromHex for UInt32LE {
|
||||
}
|
||||
}
|
||||
|
||||
-#[derive(Debug)]
|
||||
+#[derive(Copy, Clone, Debug)]
|
||||
#[repr(C, packed)]
|
||||
pub(crate) struct UInt64LE {
|
||||
bytes: [u8; 8],
|
|
@ -1,89 +0,0 @@
|
|||
core issue: https://github.com/rust-lang/rust-bindgen/issues/2312
|
||||
upstream: https://github.com/signalapp/boring/pull/19
|
||||
upstream's upstream: https://github.com/cloudflare/boring/pull/110
|
||||
|
||||
--- ./Cargo.toml.orig
|
||||
+++ ./Cargo.toml
|
||||
@@ -25,3 +25,6 @@
|
||||
# Use our fork of curve25519-dalek for eventual zkgroup support.
|
||||
curve25519-dalek = { git = 'https://github.com/signalapp/curve25519-dalek', branch = 'lizard2' }
|
||||
boring = { git = 'https://github.com/signalapp/boring', branch = 'libsignal'}
|
||||
+
|
||||
+[patch.'https://github.com/signalapp/boring']
|
||||
+boring-sys = { git = 'https://github.com/selfisekai/boring-cf', branch = 'i109-signal', package = 'boring-sys' }
|
||||
--- ./Cargo.lock.orig
|
||||
+++ ./Cargo.lock
|
||||
@@ -206,9 +206,9 @@
|
||||
|
||||
[[package]]
|
||||
name = "bindgen"
|
||||
-version = "0.60.1"
|
||||
+version = "0.62.0"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "062dddbc1ba4aca46de6338e2bf87771414c335f7b2f2036e8f3e9befebf88e6"
|
||||
+checksum = "c6720a8b7b2d39dd533285ed438d458f65b31b5c257e6ac7bb3d7e82844dd722"
|
||||
dependencies = [
|
||||
"bitflags",
|
||||
"cexpr",
|
||||
@@ -221,6 +221,7 @@
|
||||
"regex",
|
||||
"rustc-hash",
|
||||
"shlex",
|
||||
+ "syn",
|
||||
]
|
||||
|
||||
[[package]]
|
||||
@@ -295,7 +296,7 @@
|
||||
[[package]]
|
||||
name = "boring-sys"
|
||||
version = "2.1.0"
|
||||
-source = "git+https://github.com/signalapp/boring?branch=libsignal#25e1dd8fa519ae90772008fbd4a284582096fece"
|
||||
+source = "git+https://github.com/selfisekai/boring-cf?branch=i109-signal#5c13f5c357c8b33c9978f2e447de2d6caf825d13"
|
||||
dependencies = [
|
||||
"bindgen",
|
||||
"cmake",
|
||||
@@ -1398,11 +1399,11 @@
|
||||
|
||||
[[package]]
|
||||
name = "proc-macro2"
|
||||
-version = "1.0.29"
|
||||
+version = "1.0.54"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "b9f5105d4fdaab20335ca9565e106a5d9b82b6219b5ba735731124ac6711d23d"
|
||||
+checksum = "e472a104799c74b514a57226160104aa483546de37e839ec50e3c2e41dd87534"
|
||||
dependencies = [
|
||||
- "unicode-xid",
|
||||
+ "unicode-ident",
|
||||
]
|
||||
|
||||
[[package]]
|
||||
@@ -1868,13 +1869,13 @@
|
||||
|
||||
[[package]]
|
||||
name = "syn"
|
||||
-version = "1.0.80"
|
||||
+version = "1.0.109"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "d010a1623fbd906d51d650a9916aaefc05ffa0e4053ff7fe601167f3e715d194"
|
||||
+checksum = "72b64191b275b66ffe2469e8af2c1cfe3bafa67b529ead792a6d0160888b4237"
|
||||
dependencies = [
|
||||
"proc-macro2",
|
||||
"quote",
|
||||
- "unicode-xid",
|
||||
+ "unicode-ident",
|
||||
]
|
||||
|
||||
[[package]]
|
||||
@@ -1981,6 +1982,12 @@
|
||||
version = "0.1.3"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
checksum = "56dee185309b50d1f11bfedef0fe6d036842e3fb77413abef29f8f8d1c5d4c1c"
|
||||
+
|
||||
+[[package]]
|
||||
+name = "unicode-ident"
|
||||
+version = "1.0.8"
|
||||
+source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
+checksum = "e5464a87b239f13a63a501f2701565754bae92d243d4bb7eb12f6d57d2269bf4"
|
||||
|
||||
[[package]]
|
||||
name = "unicode-segmentation"
|
|
@ -1,20 +0,0 @@
|
|||
--- ./package.json.orig
|
||||
+++ ./package.json
|
||||
@@ -431,7 +431,6 @@
|
||||
"libtextsecure/**",
|
||||
"ts/**/*.js",
|
||||
"ts/*.js",
|
||||
- "!build",
|
||||
"!ts/{storybook,test-node,test-mock,test-both,test-electron}",
|
||||
"!**/{tsconfig,bower,component}.json",
|
||||
"!**/.{github,husky,grenrc,npmrc,nycrc,taprc,bithoundrc}",
|
||||
@@ -468,9 +467,7 @@
|
||||
"!node_modules/spellchecker/vendor/hunspell/**/*",
|
||||
"!**/node_modules/*/{CHANGELOG.md,README.md,README,readme.md,readme,test,__tests__,tests,powered-test,example,examples,*.d.ts,.snyk-*.flag,benchmark}",
|
||||
"!**/node_modules/.bin",
|
||||
- "!**/node_modules/**/build/**",
|
||||
"node_modules/intl-tel-input/build/**",
|
||||
- "!**/node_modules/**/prebuilds/**",
|
||||
"!**/*.{o,hprof,orig,pyc,pyo,rbc,c,h,m}",
|
||||
"!**/._*",
|
||||
"!**/{.DS_Store,.git,.hg,.svn,CVS,RCS,SCCS,__pycache__,thumbs.db,.gitignore,.gitattributes,.flowconfig,.yarn-metadata.json,.idea,appveyor.yml,.travis.yml,circle.yml,npm-debug.log,.nyc_output,yarn.lock,.yarn-integrity}",
|
|
@ -1,14 +0,0 @@
|
|||
--- a/BUILD.gn
|
||||
+++ b/BUILD.gn
|
||||
@@ -480,11 +480,6 @@
|
||||
"rtc_base",
|
||||
"sdk",
|
||||
"video",
|
||||
-
|
||||
- # Added by RingRTC
|
||||
- # Necessary for use_custom_libcxx=true,
|
||||
- # which is in turn necessary for deploying to Ubuntu 16.04.
|
||||
- "//build/config:shared_library_deps",
|
||||
]
|
||||
|
||||
if (rtc_include_builtin_audio_codecs) {
|
|
@ -1,22 +0,0 @@
|
|||
this breaks the clang include path
|
||||
--
|
||||
--- a/build/config/compiler/BUILD.gn
|
||||
+++ a/build/config/compiler/BUILD.gn
|
||||
@@ -1310,7 +1310,7 @@
|
||||
# paths to the tools it invokes. We don't want this because we don't
|
||||
# really need it and it can mess up the goma cache entries.
|
||||
if (is_clang && (!is_nacl || is_nacl_saigo)) {
|
||||
- cflags += [ "-no-canonical-prefixes" ]
|
||||
+ #cflags += [ "-no-canonical-prefixes" ]
|
||||
|
||||
# Same for links: Let the compiler driver invoke the linker
|
||||
# with a relative path and pass relative paths to built-in
|
||||
@@ -1319,7 +1319,7 @@
|
||||
# We don't link on goma, so this change is just for cleaner
|
||||
# internal linker invocations, for people who work on the build.
|
||||
if (!is_win) {
|
||||
- ldflags += [ "-no-canonical-prefixes" ]
|
||||
+ #ldflags += [ "-no-canonical-prefixes" ]
|
||||
}
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue