testing/py3-django-q: sync with aports
This commit is contained in:
parent
038744fa84
commit
0e800ce8c2
2 changed files with 27 additions and 3 deletions
|
@ -4,7 +4,7 @@
|
||||||
pkgname=py3-django-q
|
pkgname=py3-django-q
|
||||||
_pyname="django-q"
|
_pyname="django-q"
|
||||||
pkgver=1.5.4
|
pkgver=1.5.4
|
||||||
pkgrel=0
|
pkgrel=1
|
||||||
arch="noarch"
|
arch="noarch"
|
||||||
pkgdesc="A multiprocessing distributed task queue for Django"
|
pkgdesc="A multiprocessing distributed task queue for Django"
|
||||||
url="https://pypi.python.org/project/$_pyname"
|
url="https://pypi.python.org/project/$_pyname"
|
||||||
|
@ -27,7 +27,7 @@ makedepends="
|
||||||
py3-gpep517
|
py3-gpep517
|
||||||
py3-installer
|
py3-installer
|
||||||
py3-wheel
|
py3-wheel
|
||||||
py3-setuptools
|
py3-poetry-core
|
||||||
"
|
"
|
||||||
checkdepends="
|
checkdepends="
|
||||||
py3-pytest
|
py3-pytest
|
||||||
|
@ -36,7 +36,9 @@ checkdepends="
|
||||||
# 'python-psutil: resource usage limit support'
|
# 'python-psutil: resource usage limit support'
|
||||||
# 'python-pymongo: MongoDB as a message broker support'
|
# 'python-pymongo: MongoDB as a message broker support'
|
||||||
options="!check" # Missing check depends
|
options="!check" # Missing check depends
|
||||||
source="$pkgname-$pkgver.tar.gz::https://github.com/django-q2/django-q2/archive/refs/tags/v$pkgver.tar.gz"
|
source="$pkgname-$pkgver.tar.gz::https://github.com/django-q2/django-q2/archive/refs/tags/v$pkgver.tar.gz
|
||||||
|
build-system.patch
|
||||||
|
"
|
||||||
builddir="$srcdir"/django-q2-$pkgver
|
builddir="$srcdir"/django-q2-$pkgver
|
||||||
subpackages="$pkgname-pyc"
|
subpackages="$pkgname-pyc"
|
||||||
|
|
||||||
|
@ -57,4 +59,5 @@ package() {
|
||||||
|
|
||||||
sha512sums="
|
sha512sums="
|
||||||
ebed301dc1f4a9854f9963137997219f08abed9c10ef86d363a658b83e17968ea5f62e5641ff7c6be92df4b7d5dc539dc1fed6def56ea4fb50ccc4ec0787bd6d py3-django-q-1.5.4.tar.gz
|
ebed301dc1f4a9854f9963137997219f08abed9c10ef86d363a658b83e17968ea5f62e5641ff7c6be92df4b7d5dc539dc1fed6def56ea4fb50ccc4ec0787bd6d py3-django-q-1.5.4.tar.gz
|
||||||
|
6c517f2abda689031fe4d62a7a7aa5db4885e1bcaedb575463eb1d065e4e7504ca0548395046d8f5efe2dd9fc7e073fbceb7447019fdde63a34d35894f14057e build-system.patch
|
||||||
"
|
"
|
||||||
|
|
21
testing/py3-django-q/build-system.patch
Normal file
21
testing/py3-django-q/build-system.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
Patch-Source: https://github.com/django-q2/django-q2/pull/131
|
||||||
|
From 2c2594348ebed7194afdda31e1d303f24f68935c Mon Sep 17 00:00:00 2001
|
||||||
|
From: ptrcnull <git@ptrcnull.me>
|
||||||
|
Date: Thu, 19 Oct 2023 17:06:29 +0200
|
||||||
|
Subject: [PATCH] Specify build system in pyproject.toml
|
||||||
|
|
||||||
|
Otherwise, trying to build the project with a tool like gpep517 or build
|
||||||
|
results in using the setuptools legacy backend instead
|
||||||
|
|
||||||
|
diff --git a/pyproject.toml b/pyproject.toml
|
||||||
|
index e785688..8de3163 100644
|
||||||
|
--- a/pyproject.toml
|
||||||
|
+++ b/pyproject.toml
|
||||||
|
@@ -1,3 +1,7 @@
|
||||||
|
+[build-system]
|
||||||
|
+requires = ["poetry-core>=1.0.0"]
|
||||||
|
+build-backend = "poetry.core.masonry.api"
|
||||||
|
+
|
||||||
|
[tool.poetry]
|
||||||
|
name = "django-q2"
|
||||||
|
version = "1.5.4"
|
Loading…
Reference in a new issue