backports/py3-komu: fix version requirements
This commit is contained in:
parent
527bd41b1a
commit
0b9c6bda0f
2 changed files with 23 additions and 6 deletions
|
@ -2,23 +2,27 @@
|
|||
# Maintainer: Drew DeVault <sir@cmpwn.com>
|
||||
pkgname=py3-kombu
|
||||
pkgver=5.2.4
|
||||
pkgrel=0
|
||||
pkgrel=1
|
||||
pkgdesc="a message queue abstraction layer"
|
||||
options="!check" # 3 Redis tests fail
|
||||
url="https://pypi.python.org/pypi/kombu/"
|
||||
url="https://pypi.org/project/kombu/"
|
||||
arch="noarch !s390x" # Limited by py3-dill
|
||||
license="BSD-3-Clause"
|
||||
depends="py3-amqp py3-vine"
|
||||
makedepends="py3-setuptools"
|
||||
makedepends="py3-setuptools py3-gpep517 py3-wheel"
|
||||
checkdepends="py3-pyro4 py3-case py3-nose py3-mock py3-tz py3-pytest py3-sqlalchemy py3-fakeredis"
|
||||
source="https://files.pythonhosted.org/packages/source/k/kombu/kombu-$pkgver.tar.gz"
|
||||
source="https://files.pythonhosted.org/packages/source/k/kombu/kombu-$pkgver.tar.gz
|
||||
fix-requirements.patch
|
||||
"
|
||||
builddir="$srcdir/kombu-$pkgver"
|
||||
|
||||
replaces="py-kombu" # Backwards compatibility
|
||||
provides="py-kombu=$pkgver-r$pkgrel" # Backwards compatibility
|
||||
|
||||
build() {
|
||||
python3 setup.py build
|
||||
gpep517 build-wheel \
|
||||
--wheel-dir dist \
|
||||
--output-fd 3 3>&1 >&2
|
||||
}
|
||||
|
||||
check() {
|
||||
|
@ -26,8 +30,11 @@ check() {
|
|||
}
|
||||
|
||||
package() {
|
||||
python3 setup.py install --prefix=/usr --root="$pkgdir"
|
||||
python3 -m installer -d "$pkgdir" \
|
||||
dist/*.whl
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
695813bee71d627649e772b45b25494784a6a81bcad92331160705e34d8b2268fa90629983ebcfd04ec23208508d422f1834cc56895532911602d58ec0090a03 kombu-5.2.4.tar.gz
|
||||
d296eba67b77d6a10176714facc45b3119a3c9dac1868cc281eea7cf3d0a6fceb4584836aea188db87eae3cae0f344a0f399e2fad248706c608ff3b1c28b3139 fix-requirements.patch
|
||||
"
|
||||
|
|
10
backports/py3-kombu/fix-requirements.patch
Normal file
10
backports/py3-kombu/fix-requirements.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
diff --git a/requirements/test.txt b/requirements/test.txt
|
||||
index 9b8ca32..dd360da 100644
|
||||
--- a/requirements/test.txt
|
||||
+++ b/requirements/test.txt
|
||||
@@ -1,4 +1,4 @@
|
||||
-pytz>dev
|
||||
+pytz
|
||||
pytest~=7.0.1
|
||||
pytest-sugar
|
||||
Pyro4
|
Loading…
Reference in a new issue